aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mono
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2015-04-25 19:10:11 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2015-04-25 19:10:17 +0200
commitfdbca71c9ef4f2eff5acef51a59c61c06e67d71f (patch)
tree120a1186b825b57ade5bd71355ecdf9e99945794 /testing/mono
parent881715a627e02c68c68e39b48b9a3b9e708e7a40 (diff)
testing/mono: new aport
Diffstat (limited to 'testing/mono')
-rw-r--r--testing/mono/APKBUILD61
-rw-r--r--testing/mono/musl-fix.patch43
2 files changed, 104 insertions, 0 deletions
diff --git a/testing/mono/APKBUILD b/testing/mono/APKBUILD
new file mode 100644
index 00000000000..d9d7951dc6d
--- /dev/null
+++ b/testing/mono/APKBUILD
@@ -0,0 +1,61 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=mono
+pkgver=3.12.1
+pkgrel=0
+pkgdesc="Free implementation of the .NET platform including runtime and compiler"
+url="http://www.mono-project.com/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="zlib-dev libgdiplus-dev"
+makedepends="$depends_dev python linux-headers autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://download.mono-project.com/sources/mono/mono-$pkgver.tar.bz2
+ musl-fix.patch"
+
+_builddir="$srcdir"/mono-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./autogen.sh \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-nls \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
+ --disable-quiet-build \
+ --disable-system-aot \
+ --disable-static \
+ --with-mcs-docs=no \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="ccab015f0c54ffeccd2924b44885809c mono-3.12.1.tar.bz2
+493f2a7df6d05f3513e5823e6ce32b87 musl-fix.patch"
+sha256sums="5d8cf153af2948c06bc9fbf5088f6834868e4db8e5f41c7cff76da173732b60d mono-3.12.1.tar.bz2
+a51ed2b5fb533794dd5ac36a40e5db08dfa2fd142fe944dc81293b3ec59b0627 musl-fix.patch"
+sha512sums="7ff87d95c347186347dc7a9ffb767112717de2b808f8f1b612c56c9eb70fdcc0c8f586989be44444509a2768e71854d8195567196c992cc2c5b184ecbe5ac190 mono-3.12.1.tar.bz2
+772740bb7a070b299dd4edac30e859588c566ed83f937f087ea2eb1e72c5ecc75fabff3f49900a5c1fb7b059404cb31c9ce3528c2614f7142d66f98ae2c3e9de musl-fix.patch"
diff --git a/testing/mono/musl-fix.patch b/testing/mono/musl-fix.patch
new file mode 100644
index 00000000000..abb97fbb18a
--- /dev/null
+++ b/testing/mono/musl-fix.patch
@@ -0,0 +1,43 @@
+--- a/libgc/os_dep.c.orig
++++ b/libgc/os_dep.c
+@@ -41,7 +41,7 @@
+ # else /* not 2 <= __GLIBC__ */
+ /* libc5 doesn't have <sigcontext.h>: go directly with the kernel */
+ /* one. Check LINUX_VERSION_CODE to see which we should reference. */
+-# include <asm/sigcontext.h>
++/*# include <asm/sigcontext.h>*/
+ # endif /* 2 <= __GLIBC__ */
+ # endif
+ # endif
+--- a/mono/metadata/file-mmap-posix.c.orig
++++ b/mono/metadata/file-mmap-posix.c
+@@ -37,6 +37,10 @@
+ #include <mono/utils/mono-memory-model.h>
+ #include <mono/utils/mono-mmap.h>
+
++#ifndef DEFFILEMODE
++#define DEFFILEMODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH) /* 0666 */
++#endif
++
+ typedef struct {
+ int kind;
+ int ref_count;
+--- a/mono/unit-tests/Makefile.am.orig
++++ b/mono/unit-tests/Makefile.am
+@@ -28,14 +28,9 @@
+ test_mono_linked_list_set_LDADD = $(TEST_LDADD)
+ test_mono_linked_list_set_LDFLAGS = $(TEST_LDFLAGS)
+
+-test_conc_hashtable_SOURCES = test-conc-hashtable.c
+-test_conc_hashtable_CFLAGS = $(TEST_CFLAGS)
+-test_conc_hashtable_LDADD = $(TEST_LDADD)
+-test_conc_hashtable_LDFLAGS = $(TEST_LDFLAGS)
++noinst_PROGRAMS = test-sgen-qsort test-gc-memfuncs test-mono-linked-list-set
+
+-noinst_PROGRAMS = test-sgen-qsort test-gc-memfuncs test-mono-linked-list-set test-conc-hashtable
+-
+-TESTS = test-sgen-qsort test-gc-memfuncs test-mono-linked-list-set test-conc-hashtable
++TESTS = test-sgen-qsort test-gc-memfuncs test-mono-linked-list-set
+
+ endif !PLATFORM_GNU
+ endif SUPPORT_BOEHM