aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mu
diff options
context:
space:
mode:
authorEivind Uggedal <eu@eju.no>2019-05-14 17:30:04 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-07-25 20:42:36 -0300
commit541f6f78f45b4b33ad3e3d172abbd9457319c3f2 (patch)
tree2e8905ca573c4e5bdbe7e565b912d9c5322c1a56 /testing/mu
parent10822f874d0e1bc1fed17f0c468f065d61d6fec3 (diff)
testing/mu: add mu4e subpkg
Diffstat (limited to 'testing/mu')
-rw-r--r--testing/mu/APKBUILD35
1 files changed, 23 insertions, 12 deletions
diff --git a/testing/mu/APKBUILD b/testing/mu/APKBUILD
index 60569b9af3e..58733a097fb 100644
--- a/testing/mu/APKBUILD
+++ b/testing/mu/APKBUILD
@@ -1,39 +1,42 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: stef <l0ls0fo2i@ctrlc.hu>
+# Contributor: Eivind Uggedal <eu@eju.no>
# Maintainer:
pkgname=mu
pkgver=1.2
-pkgrel=0
+pkgrel=1
pkgdesc="A collection of utilities for indexing and searching Maildirs"
arch="x86 x86_64 ppc64le"
url="http://www.djcbsoftware.nl/code/mu"
license="GPL-3.0"
depends="sqlite"
-makedepends="xapian-core-dev gmime-dev sqlite-dev autoconf automake libtool"
-install=""
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/djcb/mu/archive/$pkgver.tar.gz
- "
+makedepends="xapian-core-dev gmime-dev sqlite-dev emacs autoconf automake
+ libtool"
+subpackages="$pkgname-doc mu4e"
+source="$pkgname-$pkgver.tar.gz::https://github.com/djcb/mu/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-build() {
- cd "$builddir"
- # msg2pdf and mug will be built only if webkitgtk is installed
+prepare() {
+ default_prepare
autoreconf --force --install
+}
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
- --localstatedir=/var
+ --localstatedir=/var \
+ --disable-webkit \
+ --disable-gtk \
+ --enable-mu4e
make
}
package() {
- cd "$builddir"
make DESTDIR=$pkgdir install
+
# if msg2pdf and mug were built, install them
# if not, remove the unneeded mug manpage
if [ -f toys/msg2pdf/msg2pdf ]; then
@@ -46,4 +49,12 @@ package() {
rm $pkgdir/usr/share/man/man1/mug.1
fi
}
+
+mu4e() {
+ pkgdesc="Emacs-based e-mail client which uses mu as its back-end"
+ depends="$pkgname=$pkgver-r$pkgrel emacs"
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/share "$subpkgdir"/usr
+}
sha512sums="eadebbaf2d6b6c604c9cebc72621fe64bd4fa7b793d02b0a029a3e970c076430e2067a05ab215652f9fc52e77e4e80401476ca5b39b294eb0b14d9082118d99a mu-1.2.tar.gz"