aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mutter
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2017-06-05 22:38:35 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2017-06-05 22:38:35 +0000
commit55e2967c27b5eee06e2aa23001e667ee70fbe2bd (patch)
tree4adaeab8ca9bfee4f86272790da0200f722509a6 /testing/mutter
parentd99c6b4f765411358c7728e8da6c59f4eb524ce5 (diff)
testing/mutter: rebase the patch
Diffstat (limited to 'testing/mutter')
-rw-r--r--testing/mutter/APKBUILD3
-rw-r--r--testing/mutter/fix-format-error.patch34
2 files changed, 11 insertions, 26 deletions
diff --git a/testing/mutter/APKBUILD b/testing/mutter/APKBUILD
index b60f6ccadb6..0f96119a2b8 100644
--- a/testing/mutter/APKBUILD
+++ b/testing/mutter/APKBUILD
@@ -33,5 +33,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="6b999a39637a8eacba5c04f07bfc64b42f4a6a8c36613c43d67a5b1a29c71deed65a77f8d09b4919577848abc7613ac5c0bc12341d5fcec48c6af104ad39f361 mutter-3.24.2.tar.xz
-7e40b42ee2e6e1a02ea616b27b7ce30f9ab9a249e1597738534aa83756adc7c8546009a5d31af4ea51d53d11695dd6d2c979d82e1fd3e4e52688964c68cfc33c fix-format-error.patch"
+sha512sums="6b999a39637a8eacba5c04f07bfc64b42f4a6a8c36613c43d67a5b1a29c71deed65a77f8d09b4919577848abc7613ac5c0bc12341d5fcec48c6af104ad39f361 mutter-3.24.2.tar.xz"
diff --git a/testing/mutter/fix-format-error.patch b/testing/mutter/fix-format-error.patch
index bb498b295e2..251425fadaa 100644
--- a/testing/mutter/fix-format-error.patch
+++ b/testing/mutter/fix-format-error.patch
@@ -1,25 +1,11 @@
-From 028157081c0428bac1269078dd7f3360e3810824 Mon Sep 17 00:00:00 2001
-From: Olav Vitters <olav@vitters.nl>
-Date: Thu, 22 Sep 2016 21:00:29 +0200
-Subject: [PATCH] Fix string format build error
-
-backends/meta-input-settings.c:1245:27: error: format '%lx' expects
-argument of type 'long unsigned int', but argument 3 has type 'guint64
-{aka long long unsigned int}' [-Werror=format=]
----
- src/backends/meta-input-settings.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/backends/meta-input-settings.c b/src/backends/meta-input-settings.c
-index ae17f7baa..74cf30afd 100644
---- a/src/backends/meta-input-settings.c
-+++ b/src/backends/meta-input-settings.c
-@@ -1242,7 +1242,7 @@ lookup_tool_settings (ClutterInputDeviceTool *tool,
+--- mutter-3.24.2.orig/src/backends/meta-input-settings.c
++++ mutter-3.24.2/src/backends/meta-input-settings.c
+@@ -1107,7 +1107,7 @@
+ }
+ else
+ {
+- path = g_strdup_printf ("/org/gnome/desktop/peripherals/stylus/%lx/", serial);
++ path = g_strdup_printf ("/org/gnome/desktop/peripherals/stylus/%" G_GUINT64_FORMAT "/", serial);
+ }
- tool_id = clutter_input_device_tool_get_id (tool);
- device_id = get_tablet_settings_id (device, lookup_mapping_info (device));
-- path = g_strdup_printf ("/org/gnome/settings-daemon/peripherals/wacom/%s/%lx/",
-+ path = g_strdup_printf ("/org/gnome/settings-daemon/peripherals/wacom/%s/%" G_GUINT64_FORMAT "/",
- device_id, tool_id);
- tool_settings = tool_settings_new (tool, path);
- g_object_set_qdata_full (G_OBJECT (tool), quark_tool_settings, tool_settings,
+ tool_settings =