aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mxml
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-28 20:57:41 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-28 20:57:41 +0000
commit2712c5dea33613e629dec952357dfd5d172ed799 (patch)
tree764b6758d8e053a07a456425dae8a1345bfd0718 /testing/mxml
parent18a73ca629b9f3bb9f47ecaa687e1bebb815ed20 (diff)
testing/mxml: upgrade to 2.11 and modernize
Diffstat (limited to 'testing/mxml')
-rw-r--r--testing/mxml/APKBUILD36
1 files changed, 10 insertions, 26 deletions
diff --git a/testing/mxml/APKBUILD b/testing/mxml/APKBUILD
index b297dba82f7..89916c1021e 100644
--- a/testing/mxml/APKBUILD
+++ b/testing/mxml/APKBUILD
@@ -1,45 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mxml
-pkgver=2.10
+pkgver=2.11
pkgrel=0
-pkgdesc="small XML library that you can use to read and write XML files"
+pkgdesc="Small XML library that you can use to read and write XML files"
url="http://www.msweet.org/projects.php?Z3"
arch="all"
license="LGPLv2"
-depends=""
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-dev $pkgname-doc"
-source="https://github.com/michaelrsweet/$pkgname/releases/download/release-$pkgver/$pkgname-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/michaelrsweet/$pkgname/releases/download/release-$pkgver/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/mxml-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
- --localstatedir=/var \
- || return 1
- make || return 1
+ --localstatedir=/var
+ make
}
package() {
- cd "$_builddir"
- make BUILDROOT="$pkgdir" install || return 1
+ cd "$builddir"
+ make BUILDROOT="$pkgdir" install
}
-md5sums="8804c961a24500a95690ef287d150abe mxml-2.10.tar.gz"
-sha256sums="267ff58b64ddc767170d71dab0c729c06f45e1df9a9b6f75180b564f09767891 mxml-2.10.tar.gz"
-sha512sums="c3838611979c4228df476166e4e987fc1ff8f9b8bd30139066b475dcd99e25be81ecc5171235bc80b1c2291c9d78c9ceae9a1dfc928272a983740d6a67372f5c mxml-2.10.tar.gz"
+sha512sums="046421f91eea16f0ca99fbf611891c367ea9c3c54d04080d08acf108d7749ad9bbf2f4b3ef234a5130f00f77618196e2c5a245f32230daf645c1f775e961d378 mxml-2.11.tar.gz"