aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mycroft-core/0004-relax-dep-requirements.patch
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-29 17:24:58 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-23 18:53:45 +0000
commit0ee0c85e64a2f4a8005eb418ead749db7c2a1320 (patch)
tree56140c359d1efb75e17f51b615f2f1d69760d144 /testing/mycroft-core/0004-relax-dep-requirements.patch
parent702017a4235d7908ca4cc066ad4526d90ff45249 (diff)
downloadaports-0ee0c85e64a2f4a8005eb418ead749db7c2a1320.tar.gz
aports-0ee0c85e64a2f4a8005eb418ead749db7c2a1320.tar.bz2
aports-0ee0c85e64a2f4a8005eb418ead749db7c2a1320.tar.xz
testing/mycroft-core: upgrade to 20.2.4
Diffstat (limited to 'testing/mycroft-core/0004-relax-dep-requirements.patch')
-rw-r--r--testing/mycroft-core/0004-relax-dep-requirements.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/testing/mycroft-core/0004-relax-dep-requirements.patch b/testing/mycroft-core/0004-relax-dep-requirements.patch
deleted file mode 100644
index 56b85a29c7..0000000000
--- a/testing/mycroft-core/0004-relax-dep-requirements.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Upstream pull-request: https://github.com/MycroftAI/mycroft-core/pull/2562
-
-From 466d39fd4057ab17492877edd18131541cd88e15 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=C3=85ke=20Forslund?= <ake.forslund@gmail.com>
-Date: Mon, 4 May 2020 09:28:48 +0200
-Subject: [PATCH] Allow building Mycroft with loose requirements
-
----
- setup.py | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/setup.py b/setup.py
-index c98f7b4f8f9..3d08cbbd943 100644
---- a/setup.py
-+++ b/setup.py
-@@ -13,6 +13,7 @@
- # limitations under the License.
- #
- from setuptools import setup, find_packages
-+import os
- import os.path
-
- BASEDIR = os.path.abspath(os.path.dirname(__file__))
-@@ -44,6 +45,9 @@ def required(requirements_file):
- """ Read requirements file and remove comments and empty lines. """
- with open(os.path.join(BASEDIR, requirements_file), 'r') as f:
- requirements = f.read().splitlines()
-+ if 'MYCROFT_LOOSE_REQUIREMENTS' in os.environ:
-+ print('USING LOOSE REQUIREMENTS!')
-+ requirements = [r.replace('==', '>=') for r in requirements]
- return [pkg for pkg in requirements
- if pkg.strip() and not pkg.startswith("#")]
-