aboutsummaryrefslogtreecommitdiffstats
path: root/testing/mycroft-skill-pokemon/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-09 22:43:56 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-10 12:04:10 +0000
commita7fd10e7bed56925f7626f7fb1f372598d437cd1 (patch)
treedcb649fa991f7a42b9d3af9aa8830ce6a098d9da /testing/mycroft-skill-pokemon/APKBUILD
parent8ef98f8a70750af3c42031c5356109388dfb3edd (diff)
testing/mycroft-skill-pokemon: new aport
Diffstat (limited to 'testing/mycroft-skill-pokemon/APKBUILD')
-rw-r--r--testing/mycroft-skill-pokemon/APKBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/mycroft-skill-pokemon/APKBUILD b/testing/mycroft-skill-pokemon/APKBUILD
new file mode 100644
index 00000000000..8f7ff3510b5
--- /dev/null
+++ b/testing/mycroft-skill-pokemon/APKBUILD
@@ -0,0 +1,20 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=mycroft-skill-pokemon
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="A skill for mycroft that will answer many questions about Pokémon"
+url="https://github.com/retrodaredevil/pokemon-skill"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-pokebase"
+source="https://github.com/retrodaredevil/pokemon-skill/archive/v$pkgver/pokemon-skill-v$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/pokemon-skill-$pkgver"
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/mycroft/skills/pokemon
+ cp -r ./* "$pkgdir"/usr/share/mycroft/skills/pokemon/
+}
+
+sha512sums="b051cd4973dba081e849ceaad6ac05d5868f1e4ce134ebaa12db32f1952598ff62b4e3e7282ad42df50ff527a696e0ae5fba23e715e6d3c47691ae732e003537 pokemon-skill-v1.1.1.tar.gz"