aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nextcloud/APKBUILD
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2016-06-29 09:24:42 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2016-06-29 09:38:33 +0000
commit66dedd32a2b5d08f9a10dbcb89b4f7e5ad05673e (patch)
treeb596f852c7e6114b3c9129171a35cade21de522c /testing/nextcloud/APKBUILD
parent312dc15a4f3c4068c67e3addfa4d76ebf6246483 (diff)
testing/nextcloud: refactor subpkgs
Anything under GIT repo https://github.com/nextcloud/server is very likely to depend on each other. So only apps outside this GIT repo have been placed into a subpkgs
Diffstat (limited to 'testing/nextcloud/APKBUILD')
-rw-r--r--testing/nextcloud/APKBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/testing/nextcloud/APKBUILD b/testing/nextcloud/APKBUILD
index 3f3f23cc59d..506ebcb6ef0 100644
--- a/testing/nextcloud/APKBUILD
+++ b/testing/nextcloud/APKBUILD
@@ -7,16 +7,17 @@ url="http://nextcloud.com"
arch="noarch"
license="AGPL"
_php=php5
-depends="$_php ${_php}-ctype ${_php}-curl ${_php}-dom ${_php}-gd ${_php}-iconv ${_php}-json ${_php}-xml
- ${_php}-xmlreader ${_php}-zlib ${_php}-zip"
+depends="$_php ${_php}-ctype ${_php}-curl ${_php}-dom ${_php}-gd ${_php}-iconv
+ ${_php}-json ${_php}-openssl ${_php}-xml ${_php}-xmlreader
+ ${_php}-zlib ${_php}-zip
+ "
depends_dev=
makedepends="$depends_dev"
install=
-subpackages="$pkgname-doc $pkgname-pgsql $pkgname-sqlite $pkgname-mysql $pkgname-encryption
- $pkgname-external $pkgname-gallery $pkgname-ldap
- $pkgname-texteditor $pkgname-pdfviewer $pkgname-videoplayer"
-#missing subpkg="$pkgname-calendar $pkgname-contacts $pkgname-documents $pkgname-mozilla_sync
-# $pkgname-music $pkgname-tasks"
+subpackages="$pkgname-doc $pkgname-activity $pkgname-firstrunwizard $pkgname-gallery
+ $pkgname-mysql $pkgname-notifications $pkgname-pdfviewer $pkgname-pgsql
+ $pkgname-sqlite $pkgname-templateeditor $pkgname-texteditor
+ $pkgname-videoplayer"
source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
@@ -109,18 +110,18 @@ _mv_app() {
chmod 770 "$subpkgdir"${_ncappsdir} || return 1
}
-encryption() {
+activity() {
arch="noarch"
- pkgdesc="Nextcloud integrated encryption support"
- depends="nextcloud ${_php}-openssl"
- _mv_app pkg encryption
+ pkgdesc="Nextcloud Activity app"
+ depends="$pkgname"
+ _mv_app pkg activity
}
-external() {
+firstrunwizard() {
arch="noarch"
- pkgdesc="Nextcloud integrated external storage support"
- depends="nextcloud ${_php}-curl ${_php}-ftp"
- _mv_app pkg files_external
+ pkgdesc="Nextcloud Firstrunwizard app"
+ depends="$pkgname"
+ _mv_app pkg firstrunwizard
}
gallery() {
@@ -130,18 +131,19 @@ gallery() {
_mv_app pkg gallery
}
-ldap() {
+notifications() {
arch="noarch"
- pkgdesc="Nextcloud integrated LDAP authentication"
- depends="nextcloud ${_php}-ldap"
- _mv_app pkg user_ldap
+ pkgdesc="Nextcloud Email notification support"
+ depends="$pkgname"
+ _mv_app pkg notifications
}
-mozilla_sync() {
+
+templateeditor() {
arch="noarch"
- pkgdesc="Nextcloud Mozilla Sync app"
- depends="nextcloud"
- _mv_app src mozilla_sync-$_mozillasyncver
+ pkgdesc="Nextcloud Email template editor app"
+ depends="$pkgname"
+ _mv_app pkg templateeditor
}
pdfviewer() {