aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ngspice/APKBUILD
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2019-08-07 10:32:51 +0200
committerMilan P. Stanić <mps@arvanta.net>2019-10-16 18:35:41 +0200
commit4453e107aefb7ac06b15ca0fa2fa29ccdb6280dd (patch)
tree8154d4eaeb6eff72e6357fd9267f3616d88064f4 /testing/ngspice/APKBUILD
parentbb4ebf8c9c3826b8960ebbbe44f9a2b4e91763ce (diff)
testing/ngspice: new aport
Diffstat (limited to 'testing/ngspice/APKBUILD')
-rw-r--r--testing/ngspice/APKBUILD54
1 files changed, 54 insertions, 0 deletions
diff --git a/testing/ngspice/APKBUILD b/testing/ngspice/APKBUILD
new file mode 100644
index 00000000000..a6174ea5c83
--- /dev/null
+++ b/testing/ngspice/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=ngspice
+pkgver=30
+pkgrel=0
+pkgdesc="open source spice simulator for electric and electronic circuits"
+url="http://ngspice.sourceforge.net/"
+arch="all"
+license="BSD-3-Clause"
+makedepends="libxaw-dev libedit-dev readline-dev"
+depends="python3"
+subpackages="$pkgname-doc $pkgname-dev"
+source="
+ https://downloads.sourceforge.net/project/$pkgname/ng-spice-rework/$pkgver/$pkgname-$pkgver.tar.gz
+ "
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-readline=yes \
+ --enable-xspice \
+ --enable-cider \
+ --enable-openmp \
+ --with-ngshared
+
+ make
+
+ # build the binary ngspice, which is only build without --with-ngshared
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-readline=yes \
+ --enable-xspice \
+ --enable-cider \
+ --enable-openmp
+
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ install -Dm755 src/.libs/libngspice.so.0.0.0 "$pkgdir/usr/lib/libngspice.so.0.0.0"
+ ln -s "libngspice.so.0.0.0" "$pkgdir/usr/lib/libngspice.so.0"
+ ln -s "libngspice.so.0.0.0" "$pkgdir/usr/lib/libngspice.so"
+}
+
+sha512sums="baa67527a05586b6da19e96203889fe013eb19a9e60b159ab9e3828dd5bb865f44bd683e622b256c3c434d77fe7adb5fe1badab75bdeaa9f24faafe7aaaae2e2 ngspice-30.tar.gz"