aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nicotine-plus/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-07-14 22:40:19 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-07-15 15:31:16 +0000
commit18a39f417d3248ec1fb0132f7e94c38d1f15dac3 (patch)
treee65bb5e7476a03ea98f5d463c3aa73450dd554a0 /testing/nicotine-plus/APKBUILD
parentb6629c5db63aabb5f75ae07e7e8b1caa37d7c062 (diff)
testing/nicotine-plus: upgrade to 2.0.0
* Upgrade to python3 and modernize.
Diffstat (limited to 'testing/nicotine-plus/APKBUILD')
-rw-r--r--testing/nicotine-plus/APKBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/testing/nicotine-plus/APKBUILD b/testing/nicotine-plus/APKBUILD
index 3b1ee65ea51..99d6be38065 100644
--- a/testing/nicotine-plus/APKBUILD
+++ b/testing/nicotine-plus/APKBUILD
@@ -1,25 +1,22 @@
# Contributor: dai9ah <dai9ah@protonmail.com>
# Maintainer: dai9ah <dai9ah@protonmail.com>
pkgname=nicotine-plus
-pkgver=1.4.1
+pkgver=2.0.0
pkgrel=0
pkgdesc="Graphical client for the SoulSeek peer-to-peer system"
url="http://nicotine-plus.org"
arch="noarch"
license="GPL-3.0-or-later"
-depends="librsvg py-gtk py-mutagen"
+depends="gtk+3.0 py3-gobject3 py3-mutagen python3"
subpackages="$pkgname-doc $pkgname-lang"
-source="$pkgname-$pkgver.tar.gz::https://github.com/Nicotine-Plus/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="nicotine-plus-$pkgver.tar.gz::https://github.com/Nicotine-Plus/nicotine-plus/archive/$pkgver.tar.gz"
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="894dfb318b205b6be21face0308f183da15772f329158c6a9a8a816dfdf231ad89245188acad5538821b2a778c8a8a6201ce8548cc58550c4eb6c0763db9d66a nicotine-plus-1.4.1.tar.gz"
+sha512sums="797536c01b42613c37c3eaaf6310016aac95bd28003f6ed5b0da1511e85f2a3d0247fdc45c9cfd510bf31183c1020c6596a3824b6b64e530b1c7f33058478ab8 nicotine-plus-2.0.0.tar.gz"