aboutsummaryrefslogtreecommitdiffstats
path: root/testing/nim
diff options
context:
space:
mode:
authorJean-Louis Fuchs <ganwell@fangorn.ch>2018-01-06 23:05:04 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-14 21:19:10 +0000
commit79323bee976f4d60d7e540658d9e1e2938d432c1 (patch)
tree01766d67c93549ea33a33c94b52afb80df05c31b /testing/nim
parente4a2bf2f3b8d31662bedd71d6bff7bcfa453dbde (diff)
testing/nim: fix coroutines
Fix coroutines by using setjmp instead of ucontext (which musl doesn't support because it deprecated)
Diffstat (limited to 'testing/nim')
-rw-r--r--testing/nim/APKBUILD8
-rw-r--r--testing/nim/nim-config-fix-coro.patch11
2 files changed, 16 insertions, 3 deletions
diff --git a/testing/nim/APKBUILD b/testing/nim/APKBUILD
index f22e984ea78..4835e03a7ea 100644
--- a/testing/nim/APKBUILD
+++ b/testing/nim/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
#
-# WARNING: Coroutines does not work and there may be more breakages!
+# WARNING: There may be breakages!
pkgname=nim
pkgver=0.17.2
pkgrel=0
@@ -14,7 +14,8 @@ subpackages="$pkgname-doc nimsuggest niminst"
source="https://nim-lang.org/download/$pkgname-$pkgver.tar.xz
$pkgname-csources-$pkgver.tar.gz::https://github.com/nim-lang/csources/archive/v$pkgver.tar.gz
niminst-fix-paths.patch
- nim-config-fix-paths.patch"
+ nim-config-fix-paths.patch
+ nim-config-fix-coro.patch"
builddir="$srcdir/$pkgname-$pkgver"
# Don't run tests on armhf, it'd take eternity...
@@ -80,4 +81,5 @@ niminst() {
sha512sums="7b4ed1eb1e9067ce72b76b95c43ec74eb38f04611776c174ba6a697254a9253fed61258712fb938f15e662bb3b0d36138194fc8fa89bbcb4d22888263e5e2880 nim-0.17.2.tar.xz
4a8f1e87bd96ab33998b0d3415c0ba9560b78795e0396d8af8b588a93c23477097f2c5388b4e612fbc142b490480326b394a933c805a3585cd6f3d7e8390e3e6 nim-csources-0.17.2.tar.gz
4ab36c5d8772567ba09b536e3dd91ddcf253892056751318ccbfce7ac24f0a646bfcd94f5dadc823c9a8394bea9614fede20c1805638052ebdbe7b5bafba4f05 niminst-fix-paths.patch
-813eb4cb93b0e9f12cb7666bef65c583390008ec09bc850f43f621688dc809bc51c105898095a8ef6316fbef49ac657a7abc75d74ad7b8cb3919c8f1a721af02 nim-config-fix-paths.patch"
+813eb4cb93b0e9f12cb7666bef65c583390008ec09bc850f43f621688dc809bc51c105898095a8ef6316fbef49ac657a7abc75d74ad7b8cb3919c8f1a721af02 nim-config-fix-paths.patch
+bc1158d06a7ea667a0fb48b054fc3e1c5e2026260443ffa4b3958f65ea2899b72b8365b77906ebe7b33500c6442405fdc9177767001a0d9a70c67b7689fbcd36 nim-config-fix-coro.patch"
diff --git a/testing/nim/nim-config-fix-coro.patch b/testing/nim/nim-config-fix-coro.patch
new file mode 100644
index 00000000000..c96ebf76fb7
--- /dev/null
+++ b/testing/nim/nim-config-fix-coro.patch
@@ -0,0 +1,11 @@
+diff -ruN a/config/nim.cfg b/config/nim.cfg
+--- a/config/nim.cfg 2018-01-06 22:48:43.920598426 +0100
++++ b/config/nim.cfg 2018-01-06 22:49:43.620979479 +0100
+@@ -9,6 +9,7 @@
+ # gcc.path %= "$CC_PATH"
+
+ cc = gcc
++define:nimCoroutinesSetjmp
+
+ # additional options always passed to the compiler:
+ --parallel_build: "0" # 0 to auto-detect number of processors