summaryrefslogtreecommitdiffstats
path: root/testing/nmap/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-03-03 14:18:01 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-03-03 14:18:01 +0000
commite040cded51db35690200e7354f35aef6b745ff0d (patch)
tree8683ea5f2c0411fe0151a6ad765167f40879db7c /testing/nmap/APKBUILD
parent8f4e071eace60d167af432469077b16f93706878 (diff)
testing/nmap: build against uclibc++
Diffstat (limited to 'testing/nmap/APKBUILD')
-rw-r--r--testing/nmap/APKBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/testing/nmap/APKBUILD b/testing/nmap/APKBUILD
index ae7be5ed19f..3b9dbd8db9f 100644
--- a/testing/nmap/APKBUILD
+++ b/testing/nmap/APKBUILD
@@ -6,15 +6,23 @@ pkgrel=0
pkgdesc="A network exploration tool and security/port scanner"
url="http:/nmap.org"
license="custom:GPL"
-depends="pcre libpcap openssl-dev lua-dev"
-makedepends="g++"
+depends="pcre libpcap openssl-dev lua-dev uclibc++"
+makedepends="uclibc++-dev libpcap-dev"
install=
subpackages="$pkgname-doc $pkgname-nse"
-source="http://nmap.org/dist/$pkgname-$pkgver.tgz"
+source="http://nmap.org/dist/$pkgname-$pkgver.tgz
+ nmap-4.53-uclibc++-output.cc.patch
+ "
build() {
cd "$srcdir/$pkgname-$pkgver"
+ for i in ../*.patch; do
+ msg "Applying $i..."
+ patch -p1 < $i || return 1
+ done
+
+ export CXX=g++-uc
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
@@ -35,4 +43,5 @@ nse() {
mv "$pkgdir"/usr/share/$pkgname/scripts "$subpkgdir"/usr/share/$pkgname/
}
-md5sums="54b5c9e3f44c1adde17df68170eb7cfe nmap-4.76.tgz"
+md5sums="54b5c9e3f44c1adde17df68170eb7cfe nmap-4.76.tgz
+507b0936aaafaeddebad309b0924de39 nmap-4.53-uclibc++-output.cc.patch"