aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml-camomile
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-13 16:26:15 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-13 16:26:15 +0100
commitd6e775b8b89cf1970f6dd1dc7f561f93ac7a2c8b (patch)
treec7e08eae64aebebb60fcadf526a572263c26c8e0 /testing/ocaml-camomile
parent3f18acf64db110be8c2731041490f86230a77ca4 (diff)
testing/ocaml-camomile: fix comments and code-style
Diffstat (limited to 'testing/ocaml-camomile')
-rw-r--r--testing/ocaml-camomile/APKBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/testing/ocaml-camomile/APKBUILD b/testing/ocaml-camomile/APKBUILD
index d8f03279a1e..cbb48447af9 100644
--- a/testing/ocaml-camomile/APKBUILD
+++ b/testing/ocaml-camomile/APKBUILD
@@ -7,7 +7,6 @@ pkgrel=2
pkgdesc="A Unicode library for OCaml"
url="https://github.com/yoriyuki/Camomile"
# x86, armhf, s390x: limited by ocaml aport
-# ppc64le: https://github.com/yoriyuki/Camomile/issues/39. Workaround by setting hard and soft stack limits
arch="all !x86 !armhf !s390x"
license="LGPL-2.0-or-later"
depends="$pkgname-data=$pkgver-r$pkgrel ocaml-runtime"
@@ -17,11 +16,14 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/yoriyuki/$_pkgname/archive/r
builddir="$srcdir/Camomile-rel-$pkgver"
build() {
- if [ "$CARCH" = "ppc64le" ]; then
- ulimit -Hs unlimited
- ulimit -Ss 65536
- fi
cd "$builddir"
+
+ # Workaround for https://github.com/yoriyuki/Camomile/issues/39.
+ if [ "$CARCH" = ppc64le ]; then
+ ulimit -Hs unlimited
+ ulimit -Ss 65536
+ fi
+
jbuilder build @install
}