aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ocaml/APKBUILD
diff options
context:
space:
mode:
authorBorys Zhukov <mp5@mp5.im>2012-04-12 02:53:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-14 00:55:30 +0000
commit0a570078bbded2980e416c9827dc5a1ed5ae2c9e (patch)
treef385c66928f996af1658421a0330ab3e121410ff /testing/ocaml/APKBUILD
parentc1b9e1083d03c2afd777474cbcfbc5cd50242091 (diff)
testing/ocaml: new aport
Diffstat (limited to 'testing/ocaml/APKBUILD')
-rw-r--r--testing/ocaml/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/testing/ocaml/APKBUILD b/testing/ocaml/APKBUILD
new file mode 100644
index 00000000000..c92ad7426e4
--- /dev/null
+++ b/testing/ocaml/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Borys Zhukov <mp5@mp5.im>
+# Maintainer: Borys Zhukov <mp5@mp5.im>
+pkgname=ocaml
+pkgver=3.12.1
+pkgrel=0
+pkgdesc="Main implementation of the Caml programming language"
+url="http://caml.inria.fr"
+arch="all"
+license="QPL-1.0/GPLv2"
+makedepends="ncurses-dev zlib-dev gdbm-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://caml.inria.fr/pub/distrib/ocaml-3.12/$pkgname-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure -cc "${CC:-gcc} -fPIC -fno-pie" \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ -no-tk \
+ || return 1
+ make -j1 world.opt || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make BINDIR="$pkgdir"/usr/bin LIBDIR="$pkgdir"/usr/lib/ocaml MANDIR="$pkgdir"/usr/share/man install || return 1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ install -Dm644 INSTALL "$pkgdir"/usr/share/doc/$pkgname/INSTALL
+ install -Dm644 Changes "$pkgdir"/usr/share/doc/$pkgname/Changes
+ install -Dm644 README "$pkgdir"/usr/share/doc/$pkgname/README
+
+ find "$pkgdir"/usr/lib/ocaml -name \*.ml -delete
+}
+md5sums="814a047085f0f901ab7d8e3a4b7a9e65 ocaml-3.12.1.tar.gz"