aboutsummaryrefslogtreecommitdiffstats
path: root/testing/opencpn/CMakeList.txt.patch
diff options
context:
space:
mode:
authorScrumpyJack <scrumpyjack@st.ilet.to>2016-07-06 09:20:19 +0000
committerBartłomiej Piotrowski <bpiotrowski@mirantis.com>2016-07-06 13:36:09 +0200
commit0bc9aa6ced4592eb4d26353d714dae0f3dfd4df8 (patch)
tree7b7ba7befc367e167c63ee5184ef0e5d9b7ee8d3 /testing/opencpn/CMakeList.txt.patch
parent80184bbe42a9ba56800ca40b6695b33bf98ad043 (diff)
testing/opencpn: new aport
OpenCPN is a cross platform electronic navigation system. http://opencpn.org
Diffstat (limited to 'testing/opencpn/CMakeList.txt.patch')
-rw-r--r--testing/opencpn/CMakeList.txt.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/testing/opencpn/CMakeList.txt.patch b/testing/opencpn/CMakeList.txt.patch
new file mode 100644
index 00000000000..8a1341d424f
--- /dev/null
+++ b/testing/opencpn/CMakeList.txt.patch
@@ -0,0 +1,13 @@
+index 967e558..27bad69 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -489,6 +489,9 @@ IF(OCPN_USE_CRASHREPORT)
+ IF(CMAKE_BUILD_TYPE MATCHES "Rel*")
+ MESSAGE (STATUS "Using Linux crash reporting")
+ ADD_DEFINITIONS(-DLINUX_CRASHRPT)
++ IF(EXISTS /etc/alpine-release)
++ SET(EXTRA_LIBS ${EXTRA_LIBS} "execinfo")
++ ENDIF(EXISTS alpine-release)
+ ENDIF(CMAKE_BUILD_TYPE MATCHES "Rel*")
+ ENDIF(NOT APPLE AND NOT QT_ANDROID AND NOT MINGW)
+ ENDIF(MSVC