aboutsummaryrefslogtreecommitdiffstats
path: root/testing/opensubdiv/APKBUILD
diff options
context:
space:
mode:
authorMark Riedesel <mark@klowner.com>2016-08-24 16:41:50 -0500
committerJakub Jirutka <jakub@jirutka.cz>2016-10-03 22:50:11 +0200
commit23dc7bb5f49535e7cb87c78fd2290290a3722de7 (patch)
tree7254a84697569b28bbb9eaa1035ddacab8232690 /testing/opensubdiv/APKBUILD
parentd08bdad70d841e8d62f1a6c7c8c560ca7639a315 (diff)
testing/opensubdiv: new aport
http://graphics.pixar.com/opensubdiv An Open-Source subdivision surface library
Diffstat (limited to 'testing/opensubdiv/APKBUILD')
-rw-r--r--testing/opensubdiv/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/opensubdiv/APKBUILD b/testing/opensubdiv/APKBUILD
new file mode 100644
index 00000000000..dd4279961ca
--- /dev/null
+++ b/testing/opensubdiv/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Mark Riedesel <mark@klowner.com>
+# Maintainer: Mark Riedesel <mark@klowner.com>
+pkgname=opensubdiv
+pkgver=3.0.5
+pkgrel=0
+pkgdesc="An Open-Source subdivision surface library"
+url="http://graphics.pixar.com/opensubdiv"
+arch="all"
+license="ASL-2.0"
+makedepends="cmake glew-dev glfw-dev doxygen py-docutils libxcursor-dev"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-tutorials $pkgname-tools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${pkgver//./_}.tar.gz"
+builddir="$srcdir/"OpenSubdiv-${pkgver//./_}
+
+build() {
+ cd "$builddir"
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DNO_TBB=TRUE \
+ -DNO_PTEX=TRUE \
+ -DNO_MAYA=TRUE \
+ -DNO_CUDA=TRUE \
+ -DNO_OPENCL=TRUE \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"/build
+ make DESTDIR="$pkgdir" install
+}
+
+tutorials() {
+ mkdir -p "$subpkgdir"/usr/bin/
+ for tut in "$pkgdir"/usr/bin/tutorials/*; do
+ mv $tut "$subpkgdir"/usr/bin/opensubdiv_${tut##*/}
+ done
+ rmdir "$pkgdir"/usr/bin/tutorials
+}
+
+tools() {
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="f16fa309b3fa3d400e6dcbf59d316dfe opensubdiv-3.0.5.tar.gz"
+sha256sums="60bb7d709adfd949ff865864b68ff3b7e97a682a1841ccc70cd60a6c5a28ff30 opensubdiv-3.0.5.tar.gz"
+sha512sums="cee4c13fd0ef0a8dac6f880bdda8b6eed1ac3c17f7eadbd5f00bb8fe0140ca12a244b7e51edc98186af0551a26ac88e402651837f3f49195d3a9697437b86bf8 opensubdiv-3.0.5.tar.gz"