summaryrefslogtreecommitdiffstats
path: root/testing/pacparser
diff options
context:
space:
mode:
authorAaron Hurt <ahurt@anbcs.com>2016-06-10 09:12:11 -0500
committerJakub Jirutka <jakub@jirutka.cz>2016-06-11 17:05:01 +0200
commit4e051e1e7a83787c77db255b7cb24b017419f857 (patch)
tree206017549c25b1a6fa856940cc750ed31b960f14 /testing/pacparser
parent0291d3f23c45addb9aa436ae4bcb4f0d25a684f8 (diff)
testing/pacparser: new aport
http://pacparser.manugarg.com A library to parse proxy auto-config (PAC) files
Diffstat (limited to 'testing/pacparser')
-rw-r--r--testing/pacparser/APKBUILD40
-rw-r--r--testing/pacparser/spidermonkey-make.patch22
2 files changed, 62 insertions, 0 deletions
diff --git a/testing/pacparser/APKBUILD b/testing/pacparser/APKBUILD
new file mode 100644
index 00000000000..442c3bfeb65
--- /dev/null
+++ b/testing/pacparser/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Aaron Hurt <ahurt@ena.com>
+# Maintainer: Aaron Hurt <ahurt@ena.com>
+pkgname=pacparser
+pkgver=1.3.6
+pkgrel=0
+pkgdesc="A library to parse proxy auto-config (PAC) files"
+url="http://pacparser.manugarg.com"
+arch="all"
+license="LGPL3+"
+depends=""
+makedepends="bash"
+subpackages="$pkgname-doc $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pacparser/pacparser/archive/$pkgver.tar.gz
+ spidermonkey-make.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ find "$builddir" -name \*.git\* -delete
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+
+ # There's some concurrency problem, so we must disable parallel build.
+ # https://github.com/pacparser/pacparser/issues/27
+ make -j1 -C src pactester
+}
+
+package() {
+ cd "$builddir"
+ make -C src DESTDIR=$pkgdir install
+}
+
+md5sums="a7b80fc8b8a4cd8d2060d23eb5f141d2 pacparser-1.3.6.tar.gz
+4387f263520837cfb272996c565a06b7 spidermonkey-make.patch"
+sha256sums="c1f6f2ccd4fec329175f882102e47c57328e8e6e16aa9dbd4f8b859f9a028e83 pacparser-1.3.6.tar.gz
+a4226b2717c0c927cefadac9f126fd4592bc44f28776ee10f1cc9eb19199fd7a spidermonkey-make.patch"
+sha512sums="9ba0eaf0f7010363897933cfa7ab4bdbc7fab488deaeab90906d2638cb8523a013d6f9b41148dea679d76809cf1ae9b2b131c0a2937d431ec234dedcdda5bb39 pacparser-1.3.6.tar.gz
+8ac324c8f53ce546f420b509e6815b08bfe176adbe9ae18b3de9455360ed7f128236e90add6e6a8e7ea991382e26633f1568fd747c936c548c7b5936b53ea656 spidermonkey-make.patch"
diff --git a/testing/pacparser/spidermonkey-make.patch b/testing/pacparser/spidermonkey-make.patch
new file mode 100644
index 00000000000..a56bd6de7a2
--- /dev/null
+++ b/testing/pacparser/spidermonkey-make.patch
@@ -0,0 +1,22 @@
+The find command used in the upstream Makefile copies identical files
+over eachother without forcing the copy. This patch adds the -f (force)
+option to the find copy command. This is not explicitly needed but does
+seem to reduce a warning.
+
+--- a/src/spidermonkey/Makefile
++++ b/src/spidermonkey/Makefile
+@@ -30,12 +30,12 @@
+
+ jslib: js-buildstamp
+ cd js/src
+- find . -name "libjs.a" -exec cp {} .. \;
++ find . -name "libjs.a" -exec cp -f {} .. \;
+
+ js-buildstamp:
+ mkdir -p js/src/$(OBJDIR)
+ CFLAGS="$(SMCFLAGS)" $(MAKE) -C js/src -f Makefile.ref libjs.a
+- find js/src -name "jsautocfg.h" -exec cp {} js/src \;
++ find js/src -name "jsautocfg.h" -exec cp -f {} js/src \;
+ touch js-buildstamp
+
+ clean: