aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pam_sqlite3/APKBUILD
diff options
context:
space:
mode:
authorbenoitm974 <yahoo@perenite.com>2017-06-26 22:06:15 +0000
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 05:33:17 +0000
commitc48514a4a8b5c5466d4383e89dc7f9c4aa525d5f (patch)
tree810d6efa6aee4abaf98a969f19375fa1cb1b4670 /testing/pam_sqlite3/APKBUILD
parentee937b01630d377f1539d916f9d3020610a1c8e9 (diff)
testing/pam_sqlite3: new aport
https://github.com/HormyAJP/pam_sqlite3 PAM Module using a sqlite3 database as a backend [TT: Add prepare(), fix configure paths]
Diffstat (limited to 'testing/pam_sqlite3/APKBUILD')
-rw-r--r--testing/pam_sqlite3/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/pam_sqlite3/APKBUILD b/testing/pam_sqlite3/APKBUILD
new file mode 100644
index 00000000000..01a88d5a67d
--- /dev/null
+++ b/testing/pam_sqlite3/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Benoit Masson <yahoo@perenite.com>
+# Maintainer: Benoit Masson <yahoo@perenite.com>
+pkgname=pam_sqlite3
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="pam_sqlite3"
+url="https://github.com/HormyAJP/pam_sqlite3"
+arch="all"
+license="GPL3"
+depends="linux-pam"
+makedepends="linux-pam-dev sqlite-dev bsd-compat-headers"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/HormyAJP/pam_sqlite3/archive/v1.0.2.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+options="!check"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir/lib/security/"
+# make DESTDIR="$pkgdir" install
+ install -c -m 755 -o root pam_sqlite3.so $pkgdir/lib/security/
+}
+
+sha512sums="c6925adeae0f22abef20b02404a64144990d604a77fea16d100174b7a68617662ad59eba466aa33d40001e07a24ec1579cc2b59a5fcd5fb5570f658ac1a2be5e pam_sqlite3-1.0.2.tar.gz"