aboutsummaryrefslogtreecommitdiffstats
path: root/testing/partclone/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-07 17:40:34 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-07 19:28:25 +0000
commita9054df604b2383ac13702905d32115887782d8e (patch)
treeab3e32dd9c9ed9384b7e5c7d98261b017d89b16f /testing/partclone/APKBUILD
parent34a26981d33487ed9c29848a541026ec2258ca6a (diff)
testing/partclone: new aport
Partition cloning tool http://partclone.org/
Diffstat (limited to 'testing/partclone/APKBUILD')
-rw-r--r--testing/partclone/APKBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/testing/partclone/APKBUILD b/testing/partclone/APKBUILD
new file mode 100644
index 00000000000..5855d2b09db
--- /dev/null
+++ b/testing/partclone/APKBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=partclone
+pkgver=0.2.24
+pkgrel=0
+pkgdesc="Partition cloning tool"
+url="http://partclone.org/"
+arch="all"
+license="GPL"
+depends=
+makedepends="e2fsprogs-dev ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/partclone/testing/src/partclone-$pkgver.tar.gz
+ memtrace.patch"
+
+# TODO:
+# libreiserfs: http://reiserfs.linux.kiev.ua
+# ntfsprogs: http://download.sf.net/linux-ntfs/%{name}-%{version}.tar.bz2
+#
+
+_builddir="$srcdir"/partclone-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+# --enable-all enable all supported file system
+# --enable-extfs enable ext2/3/4 file system
+# --enable-xfs enable XFS file system
+# --enable-reiserfs enable REISERFS 3.6/3.6 file system
+# --enable-reiser4 enable Reiser4 file system
+# --enable-hfsp enable HFS plus file system
+# --enable-fat enable FAT file system
+# --enable-ntfs enable NTFS file system
+# --enable-ufs enable UFS(1/2) file system
+# --enable-vmfs enable vmfs file system
+# --enable-jfs enable jfs file system
+# --enable-btrfs enable btrfs file system
+## --enable-xfs \
+ ac_cv_lib_rt_aio_init=yes ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-extfs \
+ --enable-fat \
+ --enable-ncursesw \
+ --disable-nls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="d2856820ed3f92e064fcbda3cd20f94e partclone-0.2.24.tar.gz
+83dfb01e5d68795266726826a49a2de8 memtrace.patch"