aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pcl/APKBUILD
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2018-04-20 17:47:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 17:56:31 +0000
commit6d21cd1bc752332602e48547caf77ac20f105b04 (patch)
treec6619aa7a68bf6eba0aeee6900ff4770dcbef329 /testing/pcl/APKBUILD
parent4bd96058749db4a0a2db2afaeb361763a11d8ea3 (diff)
testing/pcl: disable failing segmentation test on ppc64le and aarch64
Diffstat (limited to 'testing/pcl/APKBUILD')
-rw-r--r--testing/pcl/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/pcl/APKBUILD b/testing/pcl/APKBUILD
index 32c1adb272c..ae68f071719 100644
--- a/testing/pcl/APKBUILD
+++ b/testing/pcl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bradley J Chambers <brad.chambers@gmail.com>
pkgname=pcl
pkgver=1.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="Point Cloud Library (PCL)"
url="https://github.com/PointCloudLibrary/pcl"
arch="all"
@@ -20,6 +20,10 @@ build() {
mkdir build && cd build
+ local disable_segtests=
+ case "$CARCH" in
+ ppc64le | aarch64) disable_segtests="-DBUILD_tests_segmentation=OFF"
+ esac
# Five tests are disabled below. This is in keeping with PCL's own
# Appveyor configuration
# (https://github.com/PointCloudLibrary/pcl/blob/master/.appveyor.yml),
@@ -50,6 +54,7 @@ build() {
-DBUILD_tests_features=OFF \
-DBUILD_tests_filters=OFF \
-DBUILD_tests_io=OFF \
+ $disable_segtests \
-DBUILD_tests_registration=OFF \
-DGTEST_SRC_DIR=$srcdir/googletest-release-$_gtestver/googletest \
-DGTEST_INCLUDE_DIR=$srcdir/googletest-release-$_gtestver/googletest/include