aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pcsc-perl/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-11-02 23:48:04 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2017-11-02 23:49:19 +0100
commitd66e5b8183de61fcbc1472383c99b80c4cf059b5 (patch)
treefcb62d29c5444ff169865c6e18bdcedcce7db39c /testing/pcsc-perl/APKBUILD
parent414b1d85dc88bd568767f07cae0d36dbcfd95d7e (diff)
testing/pcsc-perl: new aport
Diffstat (limited to 'testing/pcsc-perl/APKBUILD')
-rw-r--r--testing/pcsc-perl/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/pcsc-perl/APKBUILD b/testing/pcsc-perl/APKBUILD
new file mode 100644
index 00000000000..72480d5477d
--- /dev/null
+++ b/testing/pcsc-perl/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Carlo Landmeter <clandmeter@alpinelinux.org>
+# Maintainer:
+pkgname=pcsc-perl
+pkgver=1.4.14
+pkgrel=0
+pkgdesc="Perl library allows to communicate with a smart card using PC/SC"
+url="http://ludovic.rousseau.free.fr/softwares/pcsc-perl/"
+arch="all"
+license="GPL-2.0"
+depends="perl"
+makedepends="pcsc-lite-dev perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://ludovic.rousseau.free.fr/softwares/pcsc-perl/pcsc-perl-$pkgver.tar.bz2"
+builddir="$srcdir/pcsc-perl-$pkgver"
+
+build() {
+ cd "$builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="202aca1c122c8b91340411a4930f6d0d6f3d439d1783b7ad5e2a727bb015704045d66b5b5ba51f567672a6256606ad26e8390b9f243e329d6ccd05146edc229c pcsc-perl-1.4.14.tar.bz2"