aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-algorithm-diff-xs
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-05-26 21:43:52 +0000
committerTBK <tbk@jjtc.eu>2019-05-27 01:54:20 +0200
commitb1b47d31de7a74c78b3e3dc525c576cda686d8aa (patch)
treeed86f1a118e9af183b254da107cf1b20b0d4b0ae /testing/perl-algorithm-diff-xs
parentaea5363c49a3d0776b492e71f51a6dfafa269354 (diff)
testing/perl-algorithm-diff-xs: modernize, fix license
Closes: GH-8170
Diffstat (limited to 'testing/perl-algorithm-diff-xs')
-rw-r--r--testing/perl-algorithm-diff-xs/APKBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/testing/perl-algorithm-diff-xs/APKBUILD b/testing/perl-algorithm-diff-xs/APKBUILD
index e8a2c8ac41b..6c17fc0a808 100644
--- a/testing/perl-algorithm-diff-xs/APKBUILD
+++ b/testing/perl-algorithm-diff-xs/APKBUILD
@@ -4,11 +4,11 @@
pkgname=perl-algorithm-diff-xs
_pkgreal=Algorithm-Diff-XS
pkgver=0.04
-pkgrel=1
+pkgrel=2
pkgdesc="Algorithm::Diff with XS core loop"
url="https://metacpan.org/release/Algorithm-Diff-XS/"
arch="all"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later Artistic-1.0-Perl"
cpandepends="perl-algorithm-diff"
depends="$cpandepends"
makedepends="perl-dev"
@@ -17,20 +17,17 @@ source="https://cpan.metacpan.org/authors/id/A/AU/AUDREYT/Algorithm-Diff-XS-$pkg
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}