aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-archive-zip/APKBUILD
diff options
context:
space:
mode:
authorLinux User <larena@df1844j.ita.wtbts.net>2009-06-05 13:56:33 +0000
committerLinux User <larena@df1844j.ita.wtbts.net>2009-06-05 13:56:33 +0000
commit51b180725061b8a9f7e2472591c76b76b4ec1995 (patch)
tree4f9b823b19e7eb4996f7912cf59455d498c7f7e1 /testing/perl-archive-zip/APKBUILD
parentb2c14b1041a89cc6855223fc226d0ba1afef2d9b (diff)
testing/perl-archive-zip: new aport
Diffstat (limited to 'testing/perl-archive-zip/APKBUILD')
-rw-r--r--testing/perl-archive-zip/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/perl-archive-zip/APKBUILD b/testing/perl-archive-zip/APKBUILD
new file mode 100644
index 00000000000..5bc66bea5a5
--- /dev/null
+++ b/testing/perl-archive-zip/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-archive-zip
+_realname=Archive-Zip
+pkgver=1.26
+pkgrel=0
+pkgdesc="Provide a perl interface to ZIP archive files."
+url="http://search.cpan.org/dist/Archive-Zip/"
+license="GPL PerlArtistic"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="a2e1cc1d99dbaebc41421295c93f61b5 Archive-Zip-1.26.tar.gz"