aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-dancer-plugin-auth-extensible
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2017-07-06 11:34:44 +0300
committerTimo Teräs <timo.teras@iki.fi>2017-07-11 14:31:24 +0300
commitdf0b993e2986312179df72379301c47cccdfe812 (patch)
treeaa2c013f2dd432fda7d86a80fcb21053948c549d /testing/perl-dancer-plugin-auth-extensible
parentaf18a742d98eb20f84ca5941dd64861bf4e821b0 (diff)
testing/perl-dancer-plugin-auth-extensible: new aport
http://search.cpan.org/dist/Dancer-Plugin-Auth-Extensible/
Diffstat (limited to 'testing/perl-dancer-plugin-auth-extensible')
-rw-r--r--testing/perl-dancer-plugin-auth-extensible/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/testing/perl-dancer-plugin-auth-extensible/APKBUILD b/testing/perl-dancer-plugin-auth-extensible/APKBUILD
new file mode 100644
index 00000000000..0f3a80aa5e2
--- /dev/null
+++ b/testing/perl-dancer-plugin-auth-extensible/APKBUILD
@@ -0,0 +1,48 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=perl-dancer-plugin-auth-extensible
+_pkgreal=Dancer-Plugin-Auth-Extensible
+pkgver=1.00
+pkgrel=0
+pkgdesc="extensible authentication framework for Dancer apps"
+url="http://search.cpan.org/dist/Dancer-Plugin-Auth-Extensible/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-dancer perl-crypt-saltedhash"
+cpanmakedepends=""
+cpancheckdepends=""
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/B/BI/BIGPRESH/$_pkgreal-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+prepare() {
+ default_prepare || return 1
+
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+}
+
+build() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+check() {
+ cd "$builddir"
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+sha512sums="e9b84ed97328d4efe53d07eb7d84a82b012a56acd5dc05de025849fe7c40875d3af52a7b1e501cd15eba0fc8b930cac32007daebf4fb75a1aa431af4bbfd1418 Dancer-Plugin-Auth-Extensible-1.00.tar.gz"