aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-email-abstract
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-28 01:17:23 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-28 01:17:23 -0300
commit9ddeb49d0a1ef07118a7009a1c46415fb52743e0 (patch)
tree2eabade3704fe12687771738623a22484268e352 /testing/perl-email-abstract
parent25c6bf6cd49cbe0137057c6a29444953f4bc07a8 (diff)
testing/perl-email-abstract: fix url fix license
Diffstat (limited to 'testing/perl-email-abstract')
-rw-r--r--testing/perl-email-abstract/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/testing/perl-email-abstract/APKBUILD b/testing/perl-email-abstract/APKBUILD
index e2751ef83d3..9522a1c8bbe 100644
--- a/testing/perl-email-abstract/APKBUILD
+++ b/testing/perl-email-abstract/APKBUILD
@@ -4,39 +4,34 @@
pkgname=perl-email-abstract
_pkgreal=Email-Abstract
pkgver=3.008
-pkgrel=1
+pkgrel=2
pkgdesc="Unified interface to mail representations"
-url="http://search.cpan.org/dist/Email-Abstract/"
+url="https://metacpan.org/release/Email-Abstract"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-mro-compat perl-email-simple perl-module-pluggable"
-cpanmakedepends=""
depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
check() {
- cd "$builddir"
make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}