aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-file-sharedir/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-31 14:30:06 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-31 14:30:06 +0000
commit2ed560bb5c20481a0648b8902716a13e6a6ecf93 (patch)
tree32673d37dc38a7b0f0fb2126c26036eec6357f5a /testing/perl-file-sharedir/APKBUILD
parent7f17c7760f6f0de88a77e2fc501a9fc376d4237b (diff)
testing/perl-file-sharedir: new aport
File::ShareDir perl module http://search.cpan.org/dist/File-ShareDir/
Diffstat (limited to 'testing/perl-file-sharedir/APKBUILD')
-rw-r--r--testing/perl-file-sharedir/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-file-sharedir/APKBUILD b/testing/perl-file-sharedir/APKBUILD
new file mode 100644
index 00000000000..3954aff8065
--- /dev/null
+++ b/testing/perl-file-sharedir/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-file-sharedir
+pkgver=1.03
+pkgrel=0
+pkgdesc="File::ShareDir perl module"
+url="http://search.cpan.org/dist/File-ShareDir/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl perl-class-inspector"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/File-ShareDir-$pkgver.tar.gz"
+
+_builddir="$srcdir"/File-ShareDir-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="333a0903db23b9097adfbeb37b99d561 File-ShareDir-1.03.tar.gz"