aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-universal-require/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-31 09:45:11 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-31 09:45:11 +0000
commit89feb683a3f1e54ee9ba29ad9a6987fc0a028655 (patch)
treec16be384d6669fc674fee4425d6f5be984d897c3 /testing/perl-universal-require/APKBUILD
parentbacce36bc32976eec09752dc19d0d4c04ca611cf (diff)
testing/perl-universal-require: new aport
Require() modules from a variable http://search.cpan.org/dist/UNIVERSAL-require/
Diffstat (limited to 'testing/perl-universal-require/APKBUILD')
-rw-r--r--testing/perl-universal-require/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-universal-require/APKBUILD b/testing/perl-universal-require/APKBUILD
new file mode 100644
index 00000000000..134e755aa1d
--- /dev/null
+++ b/testing/perl-universal-require/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-universal-require
+pkgver=0.13
+pkgrel=0
+pkgdesc="Require() modules from a variable"
+url="http://search.cpan.org/dist/UNIVERSAL-require/"
+arch="noarch"
+license="GPL+ or Artistic"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MS/MSCHWERN/UNIVERSAL-require-$pkgver.tar.gz"
+
+_builddir="$srcdir"/UNIVERSAL-require-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="e6ea431fac9524077414d531a8cc203c UNIVERSAL-require-0.13.tar.gz"