summaryrefslogtreecommitdiffstats
path: root/testing/perl-unix-syslog/APKBUILD
diff options
context:
space:
mode:
authorLinux User <larena@df1844j.ita.wtbts.net>2009-06-05 13:56:34 +0000
committerLinux User <larena@df1844j.ita.wtbts.net>2009-06-05 13:56:34 +0000
commit1c823be22d48ffeec4899983252020562c95c3ce (patch)
tree02c8ffd7c89440bb7c0670c236121aef08b07bf8 /testing/perl-unix-syslog/APKBUILD
parent6f15c81d1009d9b3cddb5d252332eeec22f64fd6 (diff)
testing/perl-unix-syslog: new aport
Diffstat (limited to 'testing/perl-unix-syslog/APKBUILD')
-rw-r--r--testing/perl-unix-syslog/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/perl-unix-syslog/APKBUILD b/testing/perl-unix-syslog/APKBUILD
new file mode 100644
index 00000000000..d201815488d
--- /dev/null
+++ b/testing/perl-unix-syslog/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname=perl-unix-syslog
+_realname=Unix-Syslog
+pkgver=1.1
+pkgrel=0
+pkgdesc="Perl interface to the UNIX syslog(3) calls"
+url="http://search.cpan.org/~mharnisch/Unix-Syslog-1.1/"
+license="unknown"
+depends="perl"
+makedepends="perl-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/M/MH/MHARNISCH/$_realname-$pkgver.tar.gz"
+
+build() {
+ cd "$srcdir/$_realname-$pkgver"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="73d78e309fe9508ffc9a54d84d79aac9 Unix-Syslog-1.1.tar.gz"