aboutsummaryrefslogtreecommitdiffstats
path: root/testing/perl-xml-tidy/APKBUILD
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-04-22 01:06:23 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-22 19:51:33 +0000
commit22e5bef521f5ae0492a8a9c5d57f2b0d21fbb6e1 (patch)
tree5a8ea5d8bc8b50cded4750a8357aae7ecbd085d3 /testing/perl-xml-tidy/APKBUILD
parent2e0429705b49283d67bd2f53033b49f88694acf6 (diff)
testing/perl-xml-tidy: new aport
Diffstat (limited to 'testing/perl-xml-tidy/APKBUILD')
-rw-r--r--testing/perl-xml-tidy/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-xml-tidy/APKBUILD b/testing/perl-xml-tidy/APKBUILD
new file mode 100644
index 00000000000..98e588b59ae
--- /dev/null
+++ b/testing/perl-xml-tidy/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-xml-tidy
+_pkgreal=XML-Tidy
+pkgver=1.20
+pkgrel=0
+pkgdesc="tidy indenting of XML documents"
+url="https://metacpan.org/release/XML-Tidy/"
+arch="noarch"
+license="GPL-3.0-only"
+cpandepends="perl-xml-xpath perl-math-basecnv"
+cpanmakedepends="perl-test-pod perl-test-pod-coverage"
+depends="$cpandepends"
+makedepends="perl-dev $cpanmakedepends"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/P/PI/PIP/XML-Tidy-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="41f2578932d7452c67f2aacee9e3600ec702178d239b46ed44e71b7ecbe4ab231ee8ccff17c671ce2de3792adc565d78d64db25f0d1bb2c7f83d50b6be04d218 XML-Tidy-1.20.tgz"