aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-couchbase/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-08-18 11:24:23 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-20 20:07:36 +0300
commitd8aaad54939a05f26bfcf4ea03b9523e74cdb56d (patch)
treed225db83523a658b7fdbcc145d0880fb6b57c136 /testing/php7-pecl-couchbase/APKBUILD
parentb594c639522166b3fd5d1ddc8b5fe1d58480a2f2 (diff)
testing/php7-pecl-couchbase: rename from php7-couchbase, modernize
Diffstat (limited to 'testing/php7-pecl-couchbase/APKBUILD')
-rw-r--r--testing/php7-pecl-couchbase/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/php7-pecl-couchbase/APKBUILD b/testing/php7-pecl-couchbase/APKBUILD
new file mode 100644
index 00000000000..5b1ecabfc49
--- /dev/null
+++ b/testing/php7-pecl-couchbase/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Nathan Johnson <nathan@nathanjohnson.info>
+# Maintainer: Nathan Johnson <nathan@nathanjohnson.info>
+pkgname=php7-pecl-couchbase
+_pkgreal=couchbase
+pkgver=2.6.0
+pkgrel=0
+pkgdesc="PHP extension for Couchbase - PECL"
+url="https://pecl.php.net/package/couchbase"
+arch="all"
+license="Apache-2.0"
+depends="php7-common php7-json php7-pecl-igbinary"
+makedepends="php7-dev autoconf libcouchbase-dev re2c zlib-dev"
+source="$pkgname-$pkgver.tgz::https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+options="!check" # require couchbase and phpunit
+builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-couchbase=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-couchbase" # for backward compatibility
+
+build() {
+ cd "$builddir"
+
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+package() {
+ local confdir="$pkgdir/etc/php7/conf.d"
+ cd "$builddir"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ mkdir -p "$confdir"
+ echo "extension=$_pkgreal.so" > "$confdir"/$_pkgreal.ini
+}
+
+sha512sums="88803d996635441f2761f6aa4a4afc49764c6c71e6677684ef62e8dcb69c9390b1f9af0e16f0b8af297c337fa78f10106c8fbfe33e9cc078f260f749d6d30d4a php7-pecl-couchbase-2.6.0.tgz"