aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-redis/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2022-04-23 00:44:29 +0300
committerAndy Postnikov <apostnikov@gmail.com>2022-04-23 00:44:37 +0300
commit3a4050c1ea8dceb3430d129161e8f5250c853d3c (patch)
treee34b044d90ff5e8878f4d3ca79fd09b9e3a3270d /testing/php7-pecl-redis/APKBUILD
parent9908531f851760fed1069e267f94e70aa421470c (diff)
testing/php7-pecl-redis: move from community
Diffstat (limited to 'testing/php7-pecl-redis/APKBUILD')
-rw-r--r--testing/php7-pecl-redis/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/php7-pecl-redis/APKBUILD b/testing/php7-pecl-redis/APKBUILD
new file mode 100644
index 00000000000..a2c050d6400
--- /dev/null
+++ b/testing/php7-pecl-redis/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-pecl-redis
+_extname=redis
+pkgver=5.3.7
+_pkgver=${pkgver/_rc/RC}
+pkgrel=0
+pkgdesc="PHP 7 extension for interfacing with Redis - PECL"
+url="https://pecl.php.net/package/redis"
+arch="all"
+license="PHP-3.01"
+depends="php7-common php7-pecl-igbinary php7-session php7-json"
+makedepends="php7-dev lz4-dev zstd-dev"
+source="php-pecl-$_extname-$_pkgver.tgz::https://pecl.php.net/get/$_extname-$_pkgver.tgz"
+builddir="$srcdir/$_extname-$_pkgver"
+provides="php7-redis=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-redis" # for backward compatibility
+
+build() {
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7 \
+ --enable-redis-igbinary \
+ --enable-redis-lz4 --with-liblz4 \
+ --enable-redis-lzf \
+ --enable-redis-zstd
+ make
+}
+
+check() {
+ # Need running redis server
+ php7 -d extension=modules/$_extname.so --ri $_extname
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+
+ local _confdir="$pkgdir"/etc/php7/conf.d
+ mkdir -p $_confdir
+ echo "extension=$_extname" > $_confdir/20_$_extname.ini
+}
+
+sha512sums="
+b945d5aa86d3f58e75094369b0f324e987202f104aca7d7b46ba23cfaed54d186bb66931e200dd16d2dbeea11732dd0311da4e3d7485c3b725027f7924652832 php-pecl-redis-5.3.7.tgz
+"