aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-pecl-uuid/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2019-03-27 16:06:51 +0200
committerAndy Postnikov <apostnikov@gmail.com>2019-04-19 02:17:17 +0300
commit862749d77131716765d06f39c24d6c386190b26d (patch)
treefe08b158e129f2da2049e08e32ea646c9fee0a89 /testing/php7-pecl-uuid/APKBUILD
parent2efd1babc8cad782b5ae883dbe9cf14b2d4e086b (diff)
testing/php7-pecl-uuid: moved from testing/php7-uuid
Diffstat (limited to 'testing/php7-pecl-uuid/APKBUILD')
-rw-r--r--testing/php7-pecl-uuid/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/php7-pecl-uuid/APKBUILD b/testing/php7-pecl-uuid/APKBUILD
new file mode 100644
index 00000000000..5258e875890
--- /dev/null
+++ b/testing/php7-pecl-uuid/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-pecl-uuid
+_pkgreal=uuid
+pkgver=1.0.4
+_pkgver=${pkgver}
+pkgrel=5
+pkgdesc="A wrapper around libuuid from the ext2utils project."
+url="https://pecl.php.net/package/$_pkgreal"
+arch="all"
+license="PHP"
+depends=""
+pecldepends="php7-dev autoconf util-linux-dev"
+makedepends="$pecldepends"
+source="https://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$_pkgver"
+provides="php7-uuid=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-uuid" # for backward compatibility
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini
+}
+
+sha512sums="989d993f8158a13026b8e5c02f4aa50489b1a946d12da81dd1fff6091839a45b180562f74c8af368a498c495477374ec9e1d536e7de0178c1f288e3abe360164 uuid-1.0.4.tgz"