aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-spx/APKBUILD
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-31 14:20:42 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-11-04 22:28:19 +0200
commit3e022d27f64d7e7c2789a5f58e77b79098733b17 (patch)
treeb6cdc6ecf0d6b2c7a7dfa3eda7860805010a34e4 /testing/php7-spx/APKBUILD
parentcd3cfc064749acdc87ea29c474eefca8debcaefd (diff)
testing/php7-spx: new aport
Diffstat (limited to 'testing/php7-spx/APKBUILD')
-rw-r--r--testing/php7-spx/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/php7-spx/APKBUILD b/testing/php7-spx/APKBUILD
new file mode 100644
index 00000000000..387d5f6eb2d
--- /dev/null
+++ b/testing/php7-spx/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andy Postnikov <apostnikov@gmail.com>
+pkgname=php7-spx
+_pkgreal=php-spx
+pkgver=0.4.1
+pkgrel=0
+pkgdesc="A simple & straight-to-the-point PHP profiling extension with its built-in web UI"
+url="https://github.com/NoiseByNorthwest/php-spx"
+arch="x86_64"
+license="GPL-3.0"
+depends="php7-common"
+makedepends="php7-dev autoconf re2c zlib-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/NoiseByNorthwest/php-spx/archive/v$pkgver.tar.gz
+ e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ cd "$builddir"
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/etc/php7/conf.d
+ echo "extension=spx.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
+}
+
+sha512sums="ba30434bfd9964919b6c8444e36ecb0db7810c9b6dc386a80a28d9e94dc4f4e96980682ee3be7eb4d893ef1d034e348fca80fa65cfcbc1aeb7191c7ac4c42945 php7-spx-0.4.1.tar.gz
+4d614d94e83d2e51828855fa4ed8d66f0fa2b626a230ead024c9349e5833f0e23db0a7473751e7d01b88ea856d0c6ff2b4448a9f84a0988e187b2862e1a49915 e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch"