aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-spx
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-11-08 01:05:05 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-08 16:33:45 +0000
commitfadf57bd4daa4efe4c6a82f4b3e69a019d6237a8 (patch)
treed621e7b71544d156448029181a1afcfd0a91a66a /testing/php7-spx
parenta0ac6f5b19483a576069f945ad034ed84e73a03b (diff)
testing/php7-spx: upgrade to 0.4.2
Diffstat (limited to 'testing/php7-spx')
-rw-r--r--testing/php7-spx/APKBUILD8
-rw-r--r--testing/php7-spx/e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch20
2 files changed, 3 insertions, 25 deletions
diff --git a/testing/php7-spx/APKBUILD b/testing/php7-spx/APKBUILD
index 387d5f6eb2d..540ed24d844 100644
--- a/testing/php7-spx/APKBUILD
+++ b/testing/php7-spx/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Postnikov <apostnikov@gmail.com>
pkgname=php7-spx
_pkgreal=php-spx
-pkgver=0.4.1
+pkgver=0.4.2
pkgrel=0
pkgdesc="A simple & straight-to-the-point PHP profiling extension with its built-in web UI"
url="https://github.com/NoiseByNorthwest/php-spx"
@@ -9,8 +9,7 @@ arch="x86_64"
license="GPL-3.0"
depends="php7-common"
makedepends="php7-dev autoconf re2c zlib-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/NoiseByNorthwest/php-spx/archive/v$pkgver.tar.gz
- e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/NoiseByNorthwest/php-spx/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
@@ -32,5 +31,4 @@ package() {
echo "extension=spx.so" > "$pkgdir"/etc/php7/conf.d/$_pkgreal.ini
}
-sha512sums="ba30434bfd9964919b6c8444e36ecb0db7810c9b6dc386a80a28d9e94dc4f4e96980682ee3be7eb4d893ef1d034e348fca80fa65cfcbc1aeb7191c7ac4c42945 php7-spx-0.4.1.tar.gz
-4d614d94e83d2e51828855fa4ed8d66f0fa2b626a230ead024c9349e5833f0e23db0a7473751e7d01b88ea856d0c6ff2b4448a9f84a0988e187b2862e1a49915 e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch"
+sha512sums="3ae1332fe9503caa264d84a4ad4c0c5dfec5345b034aa17c5443f6acf14745f6faac286f262e1139cc2ab3e4a2ebc84e9f80cfe5a94dc82697f00e8b9d0c544f php7-spx-0.4.2.tar.gz"
diff --git a/testing/php7-spx/e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch b/testing/php7-spx/e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch
deleted file mode 100644
index b3fa881f3b3..00000000000
--- a/testing/php7-spx/e795d3eeb099e77a9e8540e26bcfab5dd0260c79.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From e795d3eeb099e77a9e8540e26bcfab5dd0260c79 Mon Sep 17 00:00:00 2001
-From: Andy Postnikov <apostnikov@gmail.com>
-Date: Fri, 2 Nov 2018 15:44:25 +0200
-Subject: [PATCH] Make spx_ui_assets_dir respect INSTALL_ROOT
-
----
- Makefile.frag | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile.frag b/Makefile.frag
-index a042552..9f3ae0b 100644
---- a/Makefile.frag
-+++ b/Makefile.frag
-@@ -1,5 +1,5 @@
-
--spx_ui_assets_dir = $(prefix)/share/misc/php-spx/assets/web-ui
-+spx_ui_assets_dir = $(INSTALL_ROOT)$(prefix)/share/misc/php-spx/assets/web-ui
-
- CFLAGS += -DSPX_HTTP_UI_ASSETS_DIR=\"$(spx_ui_assets_dir)\"
-