aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-tideways_xhprof
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-06 01:16:17 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-06 01:16:17 +0100
commitbc73381768736ec8c592207106b1721ecd6e24ea (patch)
tree316ab96470c739fa2f6941f4750f13fe9c0f3c38 /testing/php7-tideways_xhprof
parent25d6fb66ba12c4df7848f87c8db5230e63ada728 (diff)
testing/php7-tideways_xhprof: improve abuild
Diffstat (limited to 'testing/php7-tideways_xhprof')
-rw-r--r--testing/php7-tideways_xhprof/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/testing/php7-tideways_xhprof/APKBUILD b/testing/php7-tideways_xhprof/APKBUILD
index 990ceddc4cb..241790ca704 100644
--- a/testing/php7-tideways_xhprof/APKBUILD
+++ b/testing/php7-tideways_xhprof/APKBUILD
@@ -6,17 +6,15 @@ _pkgreal=php-xhprof-extension
pkgver=5.0_beta2
_pkgver=${pkgver/_/-}
pkgrel=0
-pkgdesc="Modern XHProf compatible Profiler for PHP 7 https://tideways.io"
-url="https://github.com/tideways/php-xhprof-extension"
+pkgdesc="Modern XHProf compatible Profiler for PHP 7"
+url="http://tideways.io"
arch="all"
license="Apache-2.0"
depends="php7"
makedepends="php7-dev autoconf"
-install=""
-subpackages=""
-source="$pkgname-$pkgver.tar.gz::https://github.com/tideways/php-xhprof-extension/archive/v$_pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/tideways/$_pkgreal/archive/v$_pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$_pkgver"
-builddir="$srcdir"/$_pkgreal-$_pkgver
build() {
cd "$builddir"
phpize7
@@ -32,7 +30,9 @@ check() {
package() {
cd "$builddir"
+
make INSTALL_ROOT="$pkgdir/" install
+
install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgext.so" > "$pkgdir"/etc/php7/conf.d/$_pkgext.ini
}