aboutsummaryrefslogtreecommitdiffstats
path: root/testing/physlock
diff options
context:
space:
mode:
authorsroracle <maxcrees@me.com>2017-06-30 20:46:17 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2017-07-02 01:30:02 +0000
commit680f404fcb96aa937350a4871ec2d8a382ace813 (patch)
tree4a49258e84676e592da5fea3bb719d156971e46a /testing/physlock
parentfe151e88ba2bafb3ff07c4e2e747d067bf978d82 (diff)
testing/physlock: new aport
Diffstat (limited to 'testing/physlock')
-rw-r--r--testing/physlock/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/physlock/APKBUILD b/testing/physlock/APKBUILD
new file mode 100644
index 00000000000..466b1ddd080
--- /dev/null
+++ b/testing/physlock/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Max Rees <maxcrees@me.com>
+# Maintainer: Max Rees <maxcrees@me.com>
+pkgname=physlock
+pkgver=0.5
+pkgrel=0
+pkgdesc="Lightweight linux console locking tool"
+url="https://github.com/muennich/physlock"
+arch="all"
+license="GPL2"
+makedepends="linux-headers"
+depends=""
+install=""
+subpackages="${pkgname}-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/muennich/physlock/archive/v${pkgver}.tar.gz"
+builddir="${srcdir}/${pkgname}-${pkgver}"
+options="!check suid"
+
+prepare() {
+ default_prepare || return
+}
+
+build() {
+ cd "$builddir"
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="0e22d2c1093556e2ca52da4ee36e53a7eebf9c2cf8e10592c95971aa3479c3ee1a31b9d71e52fca715a483f22740f6cf9a3c167fb61e4c6034a2ecf900fd5f9d ${pkgname}-${pkgver}.tar.gz"