aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pixiewps
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-11-14 09:28:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-11-14 09:28:08 +0000
commite8603102422b6e0be62d51fabaeec2bc1acc19fc (patch)
treef03c2c323c66d0b7a401cd80324f9184e7ba2d6e /testing/pixiewps
parent67810b60f17a3b25646de9d119eae385756e0e69 (diff)
testing/pixiewps: new aport
Diffstat (limited to 'testing/pixiewps')
-rw-r--r--testing/pixiewps/APKBUILD29
-rw-r--r--testing/pixiewps/make-bindir.patch13
2 files changed, 42 insertions, 0 deletions
diff --git a/testing/pixiewps/APKBUILD b/testing/pixiewps/APKBUILD
new file mode 100644
index 00000000000..4f11c661d2b
--- /dev/null
+++ b/testing/pixiewps/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=pixiewps
+pkgver=1.2.2
+pkgrel=0
+pkgdesc="An offline WPS bruteforce utility"
+url="https://github.com/wiire/pixiewps"
+arch="all"
+license="GPL3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/wiire/$pkgname/archive/v$pkgver.tar.gz
+make-bindir.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"/src
+ make || return 1
+}
+
+package() {
+ cd "$builddir"/src
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="52c0cd20eff10c5c422980a13fc86730 pixiewps-1.2.2.tar.gz
+245b6dd6e447e8a3e2b5dfa632d521ce make-bindir.patch"
+sha256sums="6da09b8ac67cd556b901606e5a72548174cd1e6a89cc52a246d49e0a5ff83db8 pixiewps-1.2.2.tar.gz
+ec6411fb8acbea863ce89ee4d2ef9178e3d540fc3b256243c6da7557ca4f4ef9 make-bindir.patch"
+sha512sums="096d9f9e50aede2a77d70b6a7bcbc6ee3559d65f70577a4669076f1d8f3d153f18ceb7ea1cbfec09d20d76ebffb189ef1f8e5047362f33ff787be20e46d3e33e pixiewps-1.2.2.tar.gz
+c317ec3ea8ec68f719e9d957d4edb20312df3783703efadee73ee59c509c63fc5f3002a4b2c7da013c0129c93467b7c59e3f591010531a2a21a5e608c155f2de make-bindir.patch"
diff --git a/testing/pixiewps/make-bindir.patch b/testing/pixiewps/make-bindir.patch
new file mode 100644
index 00000000000..8456654c280
--- /dev/null
+++ b/testing/pixiewps/make-bindir.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile b/src/Makefile
+index c800ed4..e2f1233 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -5,7 +5,7 @@ CRYPTO = crypto/sha256.c crypto/md.c crypto/md_wrap.c
+ SOURCE = $(TARGET).c random_r.c $(CRYPTO)
+ PREFIX = $(DESTDIR)/usr
+ BINDIR = $(PREFIX)/bin
+-LOCDIR = $(PREFIX)/local/bin
++LOCDIR = /usr/bin
+
+ all:
+ $(CC) $(CCFLAGS) -o $(TARGET) $(SOURCE)