aboutsummaryrefslogtreecommitdiffstats
path: root/testing/plasma-pa/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-06-19 01:54:23 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-06-19 22:33:44 -0300
commitf92c831b951462fd1a1e842d3d8b94725df43810 (patch)
treee93836d07bd34f741861da806dbad65f18dcad05 /testing/plasma-pa/APKBUILD
parent0a6ddb9d86263123d55d06c349950c50644545ec (diff)
testing/plasma-pa: new aport
Diffstat (limited to 'testing/plasma-pa/APKBUILD')
-rw-r--r--testing/plasma-pa/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/plasma-pa/APKBUILD b/testing/plasma-pa/APKBUILD
new file mode 100644
index 00000000000..f22a014c9a5
--- /dev/null
+++ b/testing/plasma-pa/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=plasma-pa
+pkgver=5.16.1
+pkgrel=0
+pkgdesc="Plasma applet for audio volume management using PulseAudio"
+arch="all"
+url="https://www.kde.org/workspaces/plasmadesktop/"
+license="LGPL-2.1-only OR LGPL-3.0-only AND GPL-2.0-only"
+depends="pulseaudio kirigami2"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtdeclarative-dev kcoreaddons-dev kdeclarative-dev kdoctools-dev kglobalaccel-dev knotifications-dev ki18n-dev plasma-workspace-dev pulseaudio-dev libcanberra-dev gconf-dev"
+source="https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ cd "$builddir"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="2f8329be0be46364af057b9230a010dd7b46af2a15376179dbcbebd71b2134ffaef13fe4bb276020e2a45c75e6e04e8efd0eb185a9277b4e165c575c35712ef4 plasma-pa-5.16.1.tar.xz"