aboutsummaryrefslogtreecommitdiffstats
path: root/testing/polkit-qt-1/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-28 20:48:03 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-29 18:46:53 +0000
commit862958439403651e514ec05b4676b7a9f27a3e10 (patch)
tree7080f6be5a37b74685d624b6a4b1e417bc42767d /testing/polkit-qt-1/APKBUILD
parent6a2c5d5ddd8fa065535197cfc75913cadca22cea (diff)
testing/polkit-qt-1: new aport
Closes GH-8204
Diffstat (limited to 'testing/polkit-qt-1/APKBUILD')
-rw-r--r--testing/polkit-qt-1/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/polkit-qt-1/APKBUILD b/testing/polkit-qt-1/APKBUILD
new file mode 100644
index 00000000000..df40ae99b2f
--- /dev/null
+++ b/testing/polkit-qt-1/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=polkit-qt-1
+pkgver=0.112.0
+pkgrel=0
+pkgdesc="Qt wrapper around polkit-1 client libraries"
+arch="all"
+url="https://www.kde.org"
+license="LGPL-2.1-only"
+depends_dev="polkit-dev"
+makedepends="$depends_dev cmake qt5-qtbase-dev"
+source="https://download.kde.org/stable/apps/KDE4.x/admin/$pkgname-$pkgver.tar.bz2"
+subpackages="$pkgname-dev"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebugInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+sha512sums="4cb17389b54a09c53052f6d72aa5cbfe09ccb19f7fd4edf8b43ccd4751f5e88609c5f89777f4af92167d32eb2ce1e78537cea7bcfb60a90072d1fe02d6a59b50 polkit-qt-1-0.112.0.tar.bz2"