aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ponyc/makefile-remove-march-mtune.patch
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-06-07 22:45:18 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-11 11:31:59 +0000
commitfb1360d4a6fdf5bce01891cac7ae11bdb4971b4c (patch)
tree9d96075e3b4f0cde321f6a6c4845d89234f326c7 /testing/ponyc/makefile-remove-march-mtune.patch
parent396b1b813c9cc8c8334c0457e11ebb3fec41f297 (diff)
testing/ponyc: upgrade to 0.28.1
* Adopt maintainership * Modernize * Use upstream `make install` * Use llvm6
Diffstat (limited to 'testing/ponyc/makefile-remove-march-mtune.patch')
-rw-r--r--testing/ponyc/makefile-remove-march-mtune.patch28
1 files changed, 21 insertions, 7 deletions
diff --git a/testing/ponyc/makefile-remove-march-mtune.patch b/testing/ponyc/makefile-remove-march-mtune.patch
index b8b45eb3850..3bee239b16d 100644
--- a/testing/ponyc/makefile-remove-march-mtune.patch
+++ b/testing/ponyc/makefile-remove-march-mtune.patch
@@ -1,20 +1,22 @@
Don't hassle with -march and -mtune, use gcc defaults.
---- a/Makefile
-+++ b/Makefile
-@@ -90,9 +90,9 @@
- destdir ?= $(prefix)/lib/pony/$(tag)
+diff --git a/Makefile-ponyc b/Makefile-ponyc
+index 50f4936..8f28e1a 100644
+--- a/Makefile-ponyc
++++ b/Makefile-ponyc
+@@ -108,9 +108,9 @@ else
+ endif
LIB_EXT ?= a
-BUILD_FLAGS = -march=$(arch) -mtune=$(tune) -Werror -Wconversion \
+BUILD_FLAGS = -Werror -Wconversion \
-Wno-sign-conversion -Wextra -Wall
--LINKER_FLAGS = -march=$(arch) -mtune=$(tune)
-+LINKER_FLAGS =
+-LINKER_FLAGS = -march=$(arch) -mtune=$(tune) $(LDFLAGS)
++LINKER_FLAGS = $(LDFLAGS)
AR_FLAGS ?= rcs
ALL_CFLAGS = -std=gnu11 -fexceptions \
-DPONY_VERSION=\"$(tag)\" -DLLVM_VERSION=\"$(llvm_version)\" \
-@@ -102,7 +102,7 @@
+@@ -120,7 +120,7 @@ ALL_CFLAGS = -std=gnu11 -fexceptions \
-DPONY_VERSION_STR=\"$(version_str)\" \
-D_FILE_OFFSET_BITS=64
ALL_CXXFLAGS = -std=gnu++11 -fno-rtti
@@ -23,3 +25,15 @@ Don't hassle with -march and -mtune, use gcc defaults.
# Determine pointer size in bits.
BITS := $(bits)
+@@ -135,11 +135,6 @@ ifeq ($(BITS),64)
+ endif
+ endif
+
+-ifneq ($(fpu),)
+- BUILD_FLAGS += -mfpu=$(fpu)
+- LINKER_FLAGS += -mfpu=$(fpu)
+-endif
+-
+ PONY_BUILD_DIR ?= build/$(config)
+ PONY_SOURCE_DIR ?= src
+ PONY_TEST_DIR ?= test