aboutsummaryrefslogtreecommitdiffstats
path: root/testing/ponyc
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-02 00:06:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-02 02:34:55 +0200
commitc77464fda48424214fe84bdde2d8b14894dcde74 (patch)
tree426249a8930f12497d1081611cdbb54cc70f5476 /testing/ponyc
parentd99c9cf879868378984c058821b77d1b14c97d70 (diff)
testing/ponyc: don't pass -march and -mtune to gcc
Diffstat (limited to 'testing/ponyc')
-rw-r--r--testing/ponyc/APKBUILD11
-rw-r--r--testing/ponyc/makefile-no-mtune.patch22
2 files changed, 7 insertions, 26 deletions
diff --git a/testing/ponyc/APKBUILD b/testing/ponyc/APKBUILD
index 04fd912dca5..6d250d00596 100644
--- a/testing/ponyc/APKBUILD
+++ b/testing/ponyc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ponyc
pkgver=0.21.3
-pkgrel=0
+pkgrel=1
pkgdesc="An open-source, actor-model, capabilities-secure, high performance programming language"
url="https://www.ponylang.org"
arch="x86_64" # TODO: enable aarch64, armhf
@@ -13,22 +13,26 @@ checkdepends="libressl-dev pcre2-dev"
makedepends="libexecinfo-dev llvm$_llvmver-dev ncurses-dev paxmark zlib-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ponylang/$pkgname/archive/$pkgver.tar.gz
- makefile-no-mtune.patch
fix-tests.patch"
builddir="$srcdir/$pkgname-$pkgver"
+# arch per gcc, used only to define PONY_ARCH.
_arch="$CARCH"
case "$CARCH" in
x86_64) _arch=x86-64;;
- arm*) _arch=armv7;;
+ armhf) _arch=armv6zk;;
esac
+# *_FLAGS= are here to avoid -march and -mtune passed to gcc.
_make_opts="arch=$_arch
config=release
default_pic=1
prefix=/usr
verbose=1
LLVM_CONFIG=/usr/lib/llvm$_llvmver/bin/llvm-config
+ BUILD_FLAGS=
+ LINKER_FLAGS=
+ LL_FLAGS=
"
build() {
@@ -79,5 +83,4 @@ dev() {
}
sha512sums="f89389142d77e93038c77d3fbe9e64c13ce76b9737430969fcdf2916023d0b7195f4d551895eab999798594352b40848be8dcc63af6927e8cc62b7c7000be65d ponyc-0.21.3.tar.gz
-2bb535b0dad3ea9aab02192c131980e5363db348bdc7f993a8e52d08fb5b08223d93c0713a9c1d420844545b5528b80403b9fdba3e0c34dd59f13366db9088c7 makefile-no-mtune.patch
46c0125b60cd1db89d7ae958602b087acb2ae1fd8298cd9141828999693a9e39b60d2dac338853406081fc1c138e506243357618197ffd118fe4ac9737bd1565 fix-tests.patch"
diff --git a/testing/ponyc/makefile-no-mtune.patch b/testing/ponyc/makefile-no-mtune.patch
deleted file mode 100644
index 4c6c2b6303b..00000000000
--- a/testing/ponyc/makefile-no-mtune.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -40,7 +40,6 @@
- # Default settings (silent release build).
- config ?= release
- arch ?= native
--tune ?= generic
- bits ?= $(shell getconf LONG_BIT)
-
- ifndef verbose
-@@ -90,9 +89,9 @@
- destdir ?= $(prefix)/lib/pony/$(tag)
-
- LIB_EXT ?= a
--BUILD_FLAGS = -march=$(arch) -mtune=$(tune) -Werror -Wconversion \
-+BUILD_FLAGS = -march=$(arch) -Werror -Wconversion \
- -Wno-sign-conversion -Wextra -Wall
--LINKER_FLAGS = -march=$(arch) -mtune=$(tune)
-+LINKER_FLAGS = -march=$(arch)
- AR_FLAGS ?= rcs
- ALL_CFLAGS = -std=gnu11 -fexceptions \
- -DPONY_VERSION=\"$(tag)\" -DLLVM_VERSION=\"$(llvm_version)\" \