aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pptpclient
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-12-31 14:00:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-12-31 14:00:09 +0000
commite864119910827fecc4cd5a51d3987598e0f9526a (patch)
tree852715afa6bf927627447bfef0a370bafdbd5704 /testing/pptpclient
parentd42dbe6e44d01f401983e5a92a366cb47a7a73cc (diff)
testing/pptpclient: new aport
Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP. http://pptpclient.sourceforge.net/
Diffstat (limited to 'testing/pptpclient')
-rw-r--r--testing/pptpclient/APKBUILD31
-rw-r--r--testing/pptpclient/pptpclient-uclibc.patch21
2 files changed, 52 insertions, 0 deletions
diff --git a/testing/pptpclient/APKBUILD b/testing/pptpclient/APKBUILD
new file mode 100644
index 00000000000..a5077f6ba01
--- /dev/null
+++ b/testing/pptpclient/APKBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=pptpclient
+pkgver=1.7.2
+pkgrel=0
+pkgdesc="Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP."
+url="http://pptpclient.sourceforge.net/"
+license="GPL"
+depends="ppp iproute2"
+makedepends=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/sourceforge/$pkgname/pptp-$pkgver.tar.gz
+ pptpclient-uclibc.patch"
+
+prepare() {
+ cd "$srcdir"/pptp-$pkgver
+ patch -p1 -i "$srcdir"/pptpclient-uclibc.patch || return 1
+ sed -i '/CFLAGS/d' Makefile
+ sed -i 's|\/bin\/ip|\/usr\/sbin\/ip|g' routing.c
+}
+
+build() {
+ cd "$srcdir"/pptp-$pkgver
+ make || return 1
+}
+
+package() {
+ cd "$srcdir"/pptp-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+md5sums="4c3d19286a37459a632c7128c92a9857 pptp-1.7.2.tar.gz
+34b643e4e4224e723f6a768018b46015 pptpclient-uclibc.patch"
diff --git a/testing/pptpclient/pptpclient-uclibc.patch b/testing/pptpclient/pptpclient-uclibc.patch
new file mode 100644
index 00000000000..aa9536e4df9
--- /dev/null
+++ b/testing/pptpclient/pptpclient-uclibc.patch
@@ -0,0 +1,21 @@
+diff --git a/pptp_compat.c b/pptp_compat.c
+index 1760a3b..6ebbea4 100644
+--- a/pptp_compat.c
++++ b/pptp_compat.c
+@@ -2,6 +2,7 @@
+ *
+ */
+
++#if defined (__SVR4) && defined (__sun) /* Solaris */
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
+@@ -14,8 +15,6 @@
+ #include <stdio.h>
+ #include "util.h"
+
+-
+-#if defined (__SVR4) && defined (__sun) /* Solaris */
+ /*
+ * daemon implementation from uClibc
+ */