aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pptpd/pptpd.patch
diff options
context:
space:
mode:
authorDanilo Godec <danilo.godec@agenda.si>2011-08-10 14:30:14 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:46:50 +0000
commitff73676914146bced1e9c9468d8ad91255125016 (patch)
tree20cf7475be3f2ae1b00f78c017f6549f60559330 /testing/pptpd/pptpd.patch
parentd5cc91e23d61e81e56b2e3c91c89551d02260dd7 (diff)
testing/pptpd: new aport
pptpd is a linux PPTP server
Diffstat (limited to 'testing/pptpd/pptpd.patch')
-rw-r--r--testing/pptpd/pptpd.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/testing/pptpd/pptpd.patch b/testing/pptpd/pptpd.patch
new file mode 100644
index 00000000000..3b4522dc76c
--- /dev/null
+++ b/testing/pptpd/pptpd.patch
@@ -0,0 +1,69 @@
+--- pptpd-1.3.4/Makefile.am
++++ pptpd-1.3.4-orig/Makefile.am
+@@ -11,7 +11,8 @@
+ ## warning with -Wmissing-prototypes).
+ ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
+ ## aren't up to it).
+-CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
++OPTFLAGS=-O2
++CFLAGS = $(OPTFLAGS) -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
+ #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
+
+--- pptpd-1.3.4/bcrelay.c
++++ pptpd-1.3.4-orig/bcrelay.c
+@@ -381,12 +381,12 @@
+ return 1;
+ }
+ }
+- if (ifin == "") {
++ if (!strlen(ifin)) {
+ syslog(LOG_INFO,"Incoming interface required!");
+ showusage(argv[0]);
+ _exit(1);
+ }
+- if (ifout == "" && ipsec == "") {
++ if (!strlen(ifout) && !strlen(ipsec)) {
+ syslog(LOG_INFO,"Listen-mode or outgoing or IPsec interface required!");
+ showusage(argv[0]);
+ _exit(1);
+@@ -870,7 +870,7 @@
+ // IPSEC tunnels are a fun one. We must change the destination address
+ // so that it will be routed to the correct tunnel end point.
+ // We can define several tunnel end points for the same ipsec interface.
+- } else if (ipsec != "" && strncmp(ifs.ifc_req[i].ifr_name, "ipsec", 5) == 0) {
++ } else if (strlen(ipsec) && strncmp(ifs.ifc_req[i].ifr_name, "ipsec", 5) == 0) {
+ if (strncmp(ifs.ifc_req[i].ifr_name, ipsec, 6) == 0) {
+ struct hostent *hp = gethostbyname(ipsec+7);
+ ioctl(s, SIOCGIFINDEX, &ifs.ifc_req[i]);
+--- pptpd-1.3.4/plugins/Makefile
++++ pptpd-1.3.4-orig/plugins/Makefile
+@@ -3,7 +3,7 @@
+ CFLAGS = $(COPTS) -I.. -I../../include -fPIC
+ LDFLAGS = -shared
+ LDADD = -lutil
+-INSTALL = install -o root
++INSTALL = install
+ prefix = /usr/local
+
+ PLUGINS = pptpd-logwtmp.so
+@@ -18,7 +18,7 @@
+ %.so: %.c
+ $(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
+
+-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
++LIBDIR = $(DESTDIR)$(prefix)/lib/pptpd
+
+ install: $(PLUGINS)
+ $(INSTALL) -d $(LIBDIR)
+--- pptpd-1.3.4/plugins/pptpd-logwtmp.c
++++ pptpd-1.3.4-orig/plugins/pptpd-logwtmp.c
+@@ -12,7 +12,7 @@
+ #include <unistd.h>
+ #include <utmp.h>
+ #include <string.h>
+-#include "pppd.h"
++#include <pppd/pppd.h>
+
+ char pppd_version[] = VERSION;
+