aboutsummaryrefslogtreecommitdiffstats
path: root/testing/prosody/APKBUILD
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-09 08:31:24 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-09 08:32:05 +0000
commit849e69af8b63f3dac3b053a9cac04d954aa34a9b (patch)
treee562098aacd9111f3d4deb66eec6d0eed04f6715 /testing/prosody/APKBUILD
parent4b55dead7e536ef352e5472a295a765194894685 (diff)
testing/prosody: compile with --ostype=linux
This is strongly recommended as the warnings indicate: pposix.c:694:2: warning: #warning Only using posix_fallocate() fallback. [-Wcpp] pposix.c:695:2: warning: #warning Linux fallocate() is strongly recommended if available: recompile with -D_GNU_SOURCE [-Wcpp]
Diffstat (limited to 'testing/prosody/APKBUILD')
-rw-r--r--testing/prosody/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/prosody/APKBUILD b/testing/prosody/APKBUILD
index e8e41af6f57..df2328550e1 100644
--- a/testing/prosody/APKBUILD
+++ b/testing/prosody/APKBUILD
@@ -3,14 +3,14 @@
_luaver=5.1
pkgname=prosody
pkgver=0.9.10
-pkgrel=3
+pkgrel=4
pkgdesc="Lua based Jabber/XMPP server"
url="http://prosody.im/"
arch="all"
license="MIT"
depends="lua${_luaver}-socket lua${_luaver}-expat lua${_luaver}-filesystem
lua${_luaver}-sec lua${_luaver} lua"
-makedepends="lua${_luaver}-dev libidn-dev openssl-dev"
+makedepends="linux-headers lua${_luaver}-dev libidn-dev openssl-dev"
install="prosody.pre-install"
subpackages="$pkgname-doc"
pkgusers="prosody"
@@ -28,6 +28,7 @@ build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc/prosody \
+ --ostype=linux \
--with-lua=/usr/bin \
--with-lua-lib=/usr/lib \
--with-lua-include=/usr/include \