aboutsummaryrefslogtreecommitdiffstats
path: root/testing/psad/APKBUILD
diff options
context:
space:
mode:
authorStuart Cardall <developer@it-offshore.co.uk>2015-12-06 09:21:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-12-09 08:39:12 +0000
commitd60570bcd35eef566bae7fffcc919f6a107543ec (patch)
tree4aaad34997cdd5d6a98ea9e645274bf3bcc0b93a /testing/psad/APKBUILD
parent37f9a85d1c798f9003972f1a6767d4220da523a5 (diff)
testing/psad: update to 2.4.2
this also fixes whois lookups causing reboots in psad / busybox
Diffstat (limited to 'testing/psad/APKBUILD')
-rw-r--r--testing/psad/APKBUILD51
1 files changed, 24 insertions, 27 deletions
diff --git a/testing/psad/APKBUILD b/testing/psad/APKBUILD
index e1cf8dedd9b..a88391155bd 100644
--- a/testing/psad/APKBUILD
+++ b/testing/psad/APKBUILD
@@ -1,14 +1,14 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=psad
-pkgver=2.4.1
-pkgrel=1
+pkgver=2.4.2
+pkgrel=0
pkgdesc="3 lightweight system daemons that analyze iptables log messages to detect port scans and other suspicious traffic"
url="http://cipherdyne.org/psad/"
arch="all"
license="GPL"
depends="perl iptables ip6tables ssmtp mailx psmisc perl-bit-vector perl-date-calc perl-iptables-chainmgr \
- perl-iptables-parse perl-net-ipv4addr perl-unix-syslog net-tools"
+ perl-iptables-parse perl-net-ipv4addr perl-unix-syslog net-tools whois"
subpackages="$pkgname-doc"
source="http://cipherdyne.org/psad/download/$pkgname-nodeps-$pkgver.tar.gz
psad.initd
@@ -21,24 +21,24 @@ build() {
cd "$_builddir"
#Set the config dirs
- sed -e "s|'/usr/sbin'|'$pkgdir/usr/sbin'|" \
- -e "s|'/usr/bin'|'$pkgdir/usr/bin'|" \
- -e "s|my \$mpath = \"/usr/share/man/man\$section\";|my \$mpath = \"$pkgdir/usr/share/man/man\$section\";|" \
- ./install.pl -i
- #/usr/sbin/psadwatchd set with last cmd
- sed -e "s|/var/log/psad|$pkgdir&|" \
- -e "s|/var/run/psad|$pkgdir&|" \
- -e "s|/var/lib/psad|$pkgdir&|" \
- -e "s|/usr/lib/psad|$pkgdir&|" \
- -e "s|/etc/psad|$pkgdir&|" \
- -e "s|/usr/bin/whois_psad|$pkgdir/usr/bin/whois|" \
- -e "s|/usr/sbin/fwcheck_psad|$pkgdir&|" \
- -e "s|/usr/sbin/kmsgsd|$pkgdir&|" \
- -e "s|/usr/sbin/psad|$pkgdir&|" \
+ sed -e "s|'/usr/sbin'|'$pkgdir/usr/sbin'|" \
+ -e "s|'/usr/bin'|'$pkgdir/usr/bin'|" \
+ -e "s|my \$mpath = \"/usr/share/man/man\$section\";|my \$mpath = \"$pkgdir/usr/share/man/man\$section\";|" \
+ ./install.pl -i
+ #/usr/sbin/psadwatchd set with last cmd
+ sed -e "s|/var/log/psad|$pkgdir&|" \
+ -e "s|/var/run/psad|$pkgdir&|" \
+ -e "s|/var/lib/psad|$pkgdir&|" \
+ -e "s|/usr/lib/psad|$pkgdir&|" \
+ -e "s|/etc/psad|$pkgdir&|" \
+ -e "s|/usr/bin/whois_psad|$pkgdir/usr/bin/whois|" \
+ -e "s|/usr/sbin/fwcheck_psad|$pkgdir&|" \
+ -e "s|/usr/sbin/kmsgsd|$pkgdir&|" \
+ -e "s|/usr/sbin/psad|$pkgdir&|" \
./psad.conf -i
- # set mail command to mailx
- sed -e 's|/bin/mail;|/usr/bin/mail;|g' -i ./psad.conf
+ # set mail command to mailx
+ sed -e 's|/bin/mail;|/usr/bin/mail;|g' -i ./psad.conf
#Disable install of generic init script & setting numeric run level
START=$(sed -n '/if ($init_dir and &is_root()) {/=' ./install.pl)
@@ -47,7 +47,7 @@ build() {
sed -e ''$START','$END'd' ./install.pl -i
#populate install.answers so build does not wait for them
- echo -e "Would you like to merge the config from the existing psad installation:\t n;" > ./install.answers
+ echo -e "Would you like to merge the config from the existing psad installation:\t y;" > ./install.answers
echo -e "Preserve any user modfications in etc psad signatures:\t y;" >> ./install.answers
echo -e "Preserve any user modfications in etc psad icmp_types:\t y;" >> ./install.answers
echo -e "Preserve any user modfications in etc psad icmp6_types:\t y;" >> ./install.answers
@@ -85,7 +85,7 @@ package() {
chmod -R o+r $pkgdir/usr/sbin/*
chmod 0700 $pkgdir/var/lib/psad
#remove whois symbolic link
- rm f $pkgdir/usr/bin/whois
+ rm -f $pkgdir/usr/bin/whois
# Fix the config
sed -e "s|$pkgdir||" $pkgdir/etc/psad/psad.conf -i
@@ -96,17 +96,14 @@ package() {
"$pkgdir"/etc/init.d/$pkgname || return 1
install -m644 -D "$srcdir"/$pkgname.confd \
"$pkgdir"/etc/conf.d/$pkgname || return 1
-
- # temporarily disable whois lookups https://github.com/mrash/psad/issues/22
- sed -i 's|ENABLE_WHOIS_LOOKUPS Y;|ENABLE_WHOIS_LOOKUPS N;|' "$pkgdir"/etc/psad/psad.conf
}
-md5sums="acbb0ab7ae9a983386b8baee2a51b929 psad-nodeps-2.4.1.tar.gz
+md5sums="e272f071dcf14175cc7841b329af1c51 psad-nodeps-2.4.2.tar.gz
b7d0fa3ee0b711a92f25ff8188dbf75b psad.initd
bc07efebb41cc23c4be129bbbacc874b psad.confd"
-sha256sums="48bd4b1adbaef628cadfc271436c0fc0ca3cc9a8e79b13cf4244cc4db2e29b6c psad-nodeps-2.4.1.tar.gz
+sha256sums="10141df4be9ea2addbbfc5823c85ed04cfa89e910d9d717526680a0f1174af12 psad-nodeps-2.4.2.tar.gz
1a5b8f1b014a9f78b43cd6e4e1006d6901a654fc51dcbe2c405d509b4a950a78 psad.initd
74c72225fa37c367a458321b737050cacaf262f32b0cc13babc54468ff1988b9 psad.confd"
-sha512sums="f1d68dd184cb4722aadd97a6d99959db325f370592ba785bf392bfd03c9497f1eaacbe497d98a7e35e91ea5fa776672fa735bbc92e4025e2978220f330d6a6e5 psad-nodeps-2.4.1.tar.gz
+sha512sums="f4c9c11e6963db0dfdf3ca2faad46ba717ad55101503887b8edba33d27fc4e93b9e2577db763294c68e35b46dbe4b499876c328527be8181e3b9fb639ffa269f psad-nodeps-2.4.2.tar.gz
f9f7e5e9da9de2f2258ae1b36e22e59faf950c7110de869c3581f7a89cd6dfdc96aa4db06a4ceca0ac016e8adbeb1e3bca3da66a565aec8a1ddf2808e93897c2 psad.initd
a80666f59356cc6157a9f5dca132991d4f1e0afda8f673d602de2557219d5521bec9ae148330e98d9483175d14d96e4cc2ccd11541d8b187b0e47f44ba4ada54 psad.confd"