aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pugixml/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2018-04-05 19:16:36 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-09 08:45:03 +0000
commit088d807377531ab7e6e338bfa6cbd0d17914e2d2 (patch)
tree620f7ce802ce496465825d6bc419dc7f9c83a564 /testing/pugixml/APKBUILD
parent77f12f10b042124bcfae0c06881a4475c1e7774a (diff)
testing/pugixml: upgrade to 1.9
Diffstat (limited to 'testing/pugixml/APKBUILD')
-rw-r--r--testing/pugixml/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/testing/pugixml/APKBUILD b/testing/pugixml/APKBUILD
index 2721adaa566..7642122d40d 100644
--- a/testing/pugixml/APKBUILD
+++ b/testing/pugixml/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Kevin Daudt <ops@ikke.info>
# Maintainer: Kevin Daudt <ops@ikke.info>
pkgname=pugixml
-pkgver=1.7
+pkgver=1.9
pkgrel=0
pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support"
url="http://pugixml.org"
@@ -9,7 +9,7 @@ arch="all"
license="MIT"
makedepends="cmake"
subpackages="$pkgname-dev"
-source="http://github.com/zeux/pugixml/releases/download/v1.7/pugixml-$pkgver.tar.gz"
+source="http://github.com/zeux/pugixml/releases/download/v${pkgver}/pugixml-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -17,8 +17,7 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=Release \
- scripts/ || return 1
+ -DCMAKE_BUILD_TYPE=Release
make
}
@@ -27,6 +26,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="17e6a3996de2942629dce65db1a701c5 pugixml-1.7.tar.gz"
-sha256sums="fbe10d46f61d769f7d92a296102e4e2bd3ee16130f11c5b10a1aae590ea1f5ca pugixml-1.7.tar.gz"
-sha512sums="708d34ba2a210df7e75faaaa8a5f170a1d43b9541b2ffe9ab4bde0101f698810617b8d61d4db2131406d22e33aa90111a0b53e7302a60126cc1ed2141deec360 pugixml-1.7.tar.gz"
+sha512sums="853a9d985aae537391c6524d5413ef4de237d99d96cc58ea7fe7152f786df1e408cdacd2e4387697e23c3e67cdc1d42b29de554501309eae16d86edd0e24785f pugixml-1.9.tar.gz"