summaryrefslogtreecommitdiffstats
path: root/testing/pugixml/APKBUILD
diff options
context:
space:
mode:
authorKevin Daudt <me@ikke.info>2016-10-17 18:24:52 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-17 14:43:05 +0100
commit35edd3767b82899cc6d58be7a722e877cc7f8fc4 (patch)
tree96940c93a1e0ad9eae223e82306dfa08e8845bdb /testing/pugixml/APKBUILD
parent27890ec72f09aa491d5317b9106021ea265be3b7 (diff)
testing/pugixml: new package
Dependency for darktable
Diffstat (limited to 'testing/pugixml/APKBUILD')
-rw-r--r--testing/pugixml/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/pugixml/APKBUILD b/testing/pugixml/APKBUILD
new file mode 100644
index 00000000000..15dfc8dff9a
--- /dev/null
+++ b/testing/pugixml/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Kevin Daudt <ops@ikke.info>
+# Maintainer: Kevin Daudt <ops@ikke.info>
+pkgname=pugixml
+pkgver=1.7
+pkgrel=0
+pkgdesc="Light-weight, simple and fast XML parser for C++ with XPath support"
+url="http://pugixml.org"
+arch="all"
+license="MIT"
+makedepends="cmake"
+source="http://github.com/zeux/pugixml/releases/download/v1.7/pugixml-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=YesPlease scripts/ || exit 1
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="17e6a3996de2942629dce65db1a701c5 pugixml-1.7.tar.gz"
+sha256sums="fbe10d46f61d769f7d92a296102e4e2bd3ee16130f11c5b10a1aae590ea1f5ca pugixml-1.7.tar.gz"
+sha512sums="708d34ba2a210df7e75faaaa8a5f170a1d43b9541b2ffe9ab4bde0101f698810617b8d61d4db2131406d22e33aa90111a0b53e7302a60126cc1ed2141deec360 pugixml-1.7.tar.gz"