aboutsummaryrefslogtreecommitdiffstats
path: root/testing/pugixml/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-11-17 15:35:37 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2016-11-17 15:35:37 +0100
commit61b1ba9bdb81e47e1398ac3e8d96c47d29f5be73 (patch)
tree89dc76a5be356482e5cc0e3797cf0ffc84fdc025 /testing/pugixml/APKBUILD
parent838767d46799cd06e0562c1e9bc440ad8f1f2798 (diff)
testing/pugixml: add dev subpkg and fix cmake
Diffstat (limited to 'testing/pugixml/APKBUILD')
-rw-r--r--testing/pugixml/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/pugixml/APKBUILD b/testing/pugixml/APKBUILD
index 15dfc8dff9a..2721adaa566 100644
--- a/testing/pugixml/APKBUILD
+++ b/testing/pugixml/APKBUILD
@@ -8,12 +8,17 @@ url="http://pugixml.org"
arch="all"
license="MIT"
makedepends="cmake"
+subpackages="$pkgname-dev"
source="http://github.com/zeux/pugixml/releases/download/v1.7/pugixml-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_SHARED_LIBS=YesPlease scripts/ || exit 1
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ scripts/ || return 1
make
}