aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-apsw
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-29 16:41:43 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-29 16:41:48 +0000
commit067f916dcd011d7841b314bf59340202efbdbd3e (patch)
treeaf2ffe2a68a6dc3ffc8292634be001475260816c /testing/py-apsw
parent1bd374ca44a9ba9de4607f1c20253451fa7698e1 (diff)
testing/py-apsw: new aport
Diffstat (limited to 'testing/py-apsw')
-rw-r--r--testing/py-apsw/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/testing/py-apsw/APKBUILD b/testing/py-apsw/APKBUILD
new file mode 100644
index 00000000000..8f36a6bd8ed
--- /dev/null
+++ b/testing/py-apsw/APKBUILD
@@ -0,0 +1,60 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-apsw
+_pkgname=apsw
+pkgver=3.19.3
+_pkgrel=r1
+pkgrel=0
+pkgdesc="Another Python SQLite Wrapper"
+url="https://github.com/rogerbinns/apsw/"
+arch="all"
+license="ZLIB"
+makedepends="python2-dev python3-dev py-setuptools sqlite-dev"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3 $pkgname-doc"
+source="$pkgname-$pkgver-$_pkgrel.tar.gz::https://github.com/rogerbinns/apsw/archive/$pkgver-$_pkgrel.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver-$_pkgrel"
+
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ python3 setup.py build
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ depends="${depends//py-/py2-}" ## remove if there are no common Python dependencies
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}" ## remove if there are no common Python dependencies
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python" ## remove if arch isn't noarch
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+doc() {
+ cd "$builddir"
+ install -Dm644 LICENSE "$subpkgdir"/usr/share/licenses/$pkgname/LICENSE
+ default_doc
+}
+sha512sums="f5d3fc82129d50906aede3ae8c11f63108769078b0d3da85b3807f5f8f914471b357f2c594be48e466afa91ecc2ebd74b6138825fab80d9a7dd6502529416020 py-apsw-3.19.3-r1.tar.gz"