aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-archive
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2013-09-28 10:03:10 +0000
committerFabian Affolter <fabian@affolter-engineering.ch>2013-09-29 14:07:41 +0000
commitd88600a07aadd8240adb8c5518f12634d4736cb2 (patch)
tree831958e17bbc2247071d9709e0a5d178aec6e028 /testing/py-archive
parent27522c7822e1b27a8ae4d6ae0be9431dcc3792cf (diff)
testing/py-archive: new aport
A Python library for extracting zip and tar archives https://github.com/gdub/python-archive
Diffstat (limited to 'testing/py-archive')
-rw-r--r--testing/py-archive/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py-archive/APKBUILD b/testing/py-archive/APKBUILD
new file mode 100644
index 00000000000..24520ee7ff1
--- /dev/null
+++ b/testing/py-archive/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-archive
+_pkgname=python-archive
+pkgver=0.2
+pkgrel=0
+pkgdesc="A Python library for extracting zip and tar archives"
+url="https://github.com/gdub/python-archive"
+arch="noarch"
+license="MIT"
+depends="python"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="d2abf4c71fd28817b0a5d27ff874470d python-archive-0.2.tar.gz"
+sha256sums="0f19c7bdd39a5f09ef86e56c5b2d5beb4a0635292639ee869a2b25bd9a2f1161 python-archive-0.2.tar.gz"
+sha512sums="5f02fe522f44989c1b61db48239cdbda5536ff685174ba93af028591eba276dcefd7655aad3a458d92140f163724d87bbe25711c78a82e06dfb382b6ae9f5683 python-archive-0.2.tar.gz"