aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-botocore
diff options
context:
space:
mode:
authorValery Kartel <valery.kartel@gmail.com>2017-12-29 11:12:54 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-12-29 10:53:46 +0100
commit0dcae28d02aa5305e5a42efc611f2af5a23fc105 (patch)
tree7ab3556f3ca56d5fd4dfa30de21ca36819788f48 /testing/py-botocore
parentca3f94eb0bc7630cfe49e89437288850cd7c33fb (diff)
testing/py-botocore: upgrade to 1.8.20
Diffstat (limited to 'testing/py-botocore')
-rw-r--r--testing/py-botocore/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/py-botocore/APKBUILD b/testing/py-botocore/APKBUILD
index 03c21acb634..d6b0c9b01db 100644
--- a/testing/py-botocore/APKBUILD
+++ b/testing/py-botocore/APKBUILD
@@ -1,14 +1,13 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py-botocore
-pkgver=1.8.11
+pkgver=1.8.20
pkgrel=0
_pkgreal=${pkgname#py-}
pkgdesc="The low-level, core functionality of Boto3"
url="https://github.com/boto/botocore"
arch="noarch"
license="ASL 2.0"
-options="!check"
depends="py-dateutil py-jmespath"
makedepends="python2-dev python3-dev py-setuptools"
subpackages="py3-$_pkgreal:_py3 py2-$_pkgreal:_py2"
@@ -21,6 +20,12 @@ build() {
python3 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py check
+ python3 setup.py check
+}
+
package() {
mkdir -p "$pkgdir"
}
@@ -46,4 +51,4 @@ _py() {
$python setup.py install --prefix=/usr --root="$subpkgdir"
}
-sha512sums="5fc323ab27542b214662b36eaee8f5961c4744e7632620f1ff5100829bff4a1241004ee1463d1a324a17ee888f8dae67bb9a9867affb381f4cd3b511c9d319d7 botocore-1.8.11.tar.gz"
+sha512sums="0b822bff75ef26c7e996e354a5c06cb50eb13d7e58f65297adcf023a81084c8b98500c08b906dcfd346e2dadcdde33d472d6d51c3e081af8667c5adcdd2deffd botocore-1.8.20.tar.gz"